Back to the main site

Epic Games Store not starting

Hi all

I recently installed Lutris (great software!!!). I’m new to linux gaming, although I used to be a heavy linux user years ago. I’m now struggling to get up to speed with all the changes in the latest years, specially around graphic drivers, wine etc.

So, here my problem: I installed the Epic Game Store via de Lutris script. It asked me to install gecko, mono and many other parts which I wasn’t sure about versioning etc. so I let the script install them all instead of going for my distros versions (Debian Buster).

Everything went OK. Now EGS is installed and I ran it for the first time. The Loading Splash screen showed up and started checking for updates. Found something and downloaded about 380MB of update. Then it installed the update and that’s it.

Every time I try to run the EGS, I get the splash screen with a green progress bar saying “verifying update” and whent he progress bar reaches 100%, the splash screen goes away and the process is stopped.

Below the logs from Lutris and my system info. You can see a lot of “Failed to open”. Some of these files are missing but some others are present. All these errors appear before the progress bar starts, so they don’t seem to stop the EGS from initializing. Then it all stops after the progress bar finishes.

Thanks in advance, I hope someone has a hint to help me out and also to help any other one with a similar problem.

[System]
OS: Debian GNU/Linux 10 buster
Arch: x86_64
Kernel: 4.19.0-8-amd64
Desktop: KDE
Display Server: x11

[CPU]
Vendor: AuthenticAMD
Model: AMD Ryzen 7 2700 Eight-Core Processor
Physical cores: 8
Logical cores: 16

[Memory]
RAM: 15.7 GB
Swap: 16.0 GB

[Graphics]
Vendor: X.Org
OpenGL Renderer: Radeon RX 580 Series (POLARIS10, DRM 3.27.0, 4.19.0-8-amd64, LLVM 7.0.1)
OpenGL Version: 4.5 (Compatibility Profile) Mesa 18.3.6
OpenGL Core: 4.5 (Core Profile) Mesa 18.3.6
OpenGL ES: OpenGL ES 3.2 Mesa 18.3.6
Vulkan: Supported

========= LUTRIS LOGS WHEN STARTING EGS =================

https://pastebin.com/PLdbKWLi

I got this one when i ran the 32 bit version:

...
LogStreaming: Warning: Failed to read file ‘…/…/…/Engine/Content/Slate/Old/DashedBorder.png’ error.
...

I got both the 32 and 64 bit version and after I pointed Lutris to the 64 bit version these messages went away.

Like this:

[wine-prefix-location]/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win64/EpicGamesLauncher.exe

This one looks interesting though:

...
Warning: Failed to read file ‘C:/ProgramData/Epic/EpicGamesLauncher/Data/Launcher.manifest’ error.
...

My guess some sort of connection problem caused some file problems.

You can try to exit Lutris, reboot first as that can fix things sometimes.

But, I would remove EGS from Lutris and delete the prefix (the folder for EGS possibly in ~/Lutris/) then install it again.

EGS works for me so it shouldn’t be broken here.

Unless maybe the installer didn’t catch a required package that needs to be installed which is the only other thing I can think of. But, I don’t think its that.

Hi,

Thanks to both!

@tfk I am not sure about 32 and 64… I actually don’t know where and how to change that. I was not able to find enough relevant info about that. I know during the installation of EGS I got several “warnings” similar to this one:

“You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.”

So you mean changing the 32/64 bit installation of the EGS inside Lutris? Of Wine? how do I change that? Sorry if they are silly questions, but I am quite confused with the bit support…

@staticjump I re-instaled EGS several times, but didn’t delete the folder inside ~/local/share/lutris/. I actually just uninstalled lutris, deleted all related files and reinstalled it… Installed again the EGS runner from the official link (got the wine 32/64 messages again). Same sequence, EGS starts by downloading a 388.5 MB update and after that… nothing. Every time I start it it says “verifying update” and exits right at the end.

Any other ideas are welcome.

Thanks again

I am not sure about 32 and 64…

No, my game (which is launched via the Epic Launcher) is installed in a standard 64bit prefix.

Like this:

[wine-prefix-location]/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win64/EpicGamesLauncher.exe

I clicked on the settings button (Configuration) for the game in Lutris and in the dialog in the Game options tab I changed the /Win32/ bit to /Win64/ in the Executable path. After checking this version was also installed of course…

Warning message
The warning you mentioned just warns that many winetricks install only 32 bit libraries. Those won’t work with a 64bit game. So before posting a bug report they advise to retest in a pure 32bit wine prefix. That’s all.

I have the same issue, but the Win64 path is missing, there’s only Win32.

The installer of my game installed Epic Launcher directly from here:

https://launcher-public-service-prod06.ol.epicgames.com/launcher/api/installer/download/EpicGamesLauncherInstaller.msi

The Lutris installer script set the prefix to 64bit explicitly. Maybe the Epic Launcher install decides installing the 64bit version on this switch?

The weird thing is that I have installed it through Lutris’ installer script. So I am unsure why it would then be missing the Win64 directory.

Which installer did you use?

This one: https://lutris.net/games/epic-games-store/

My game is Phoenix Point:

The installers are very similar. One difference I see is that the EGS installer sets the prefix to emulate Windows 7 where the Phoenix Point version doesn’t.

You could run the installer for Phoenix Point as this one only installs EGS. Just to check if this makes a difference. Note that the installer lets the prefix point to EGS in the Win32 directory. If the directory is available then the prefix must be pointed to this version.

Hmm, so using Phoenix Point, I get an error about there being a problem with my graphics card. The difference being that vkd3d is disabled in Phoenix Point. Enabling this gives me the same behaviour as the EGS installer.

My installation is definitely Win64 because if I change the EGS runner to use Win32, it fails saying the installation is for Win64. But I still get those error messages.

However, I’ve seen some logs from other people and they can run the EGS even with those messages in the logs. So the problem seems to be different.

Another issue I have which might be or might not be related is that most games on Steam do not work for me with the default Photon 5, when I switch to an older version (photon 4.13), most of them work. But I have no idea what photon is and whether the Lutris runner uses it… Sorry if it is totally unrelated.

I just used your link to install phoenix point and after installing, I get the same message as @Oipo

Enabling vkd3d on the lutris runner configuration of Phoenix Point does as well result in the same behavior as with the other installer.

phoenixpoint

Have you read the reported issue here:

Check the checkbox Show solved issues and search for There is a problem with your graphics card.

Some are mentioning there are some missing Vulkan libraries.

Hey!!! It worked!!!

I didn’t even realise there were hidden posts, sorry about that.

I tried first by disabling dxvk and it started immediately! I will later try by installing other vulkan dependencies that might be missing.

Thanks a lot! Let’s hope games work now.

3 Likes

I had to both disable dxvk as well as disable the “prefer system libraries” option. But then it started working! Thanks so much guys.

2 Likes

This worked for me too!