Back to the main site

Epic Games Store EOS-ERR-1603

If you are having difficulty installing the Epic Online Services (error EOS-ERR-1603), you are missing the .Net Framework 3.5 in your wine prefix. Use wine tricks to add it to this prefix (Install a Windows DLL or Component, dotnet35). Installation takes a while and has no displays, so be patient. When wine tricks returns, you can restart the Epic Games Store and install the Epic Online Services from the Settings menu.

1 Like

i suggest you to use heroic launcher, it s an unoficial epic games launcher with active devlopement

1 Like