Back to the main site

Epic Games Launcher Error SU-PQR1603

Hello Everyone,

The epic games launcher got an update today and when ever I try to update, I get this Error SU-PQR1603.
I did some googling and I found that you just need to add -SkipBuildPatchPrereq lunch argument.
But lutris already has this in by default.

Picture:
Imgur

Any ideas?

I’m having the same problem. Looks like Epic pushed an update that broke things

Anyone have a workaround yet? I am facing the same issue. Also does anyone have a wine bug report filled yet?

Updating with a fix that worked for me:

Running:
WINEPREFIX=~/Games/epic-games-store WINE=~/.local/share/lutris/runners/wine/ge-protonified-4.9-x86_64/bin/wine ~/.local/share/lutris/runtime/winetricks/winetricks dotnet48
Fixed the issue for me. After getting dotnet 4.8 installed, Epic games launcher was able to complete the update successfully.

3 Likes

Were re-installing my system and installed Lutris and EGL again. Everything works fine.

This worked for me, mind you I did do a complete re-install too.

Can confirm that this works without a complete reinstall. Just used winetricks to install dotnet 4.8. Still got some kind of dll error message but it’s up and running without any other issues. Thanks for the quick fix, @jdjb