Back to the main site

Epic Games Launcher doesn't launch

Is the EGL bugged? I tried it with the Lutris 6.0 RC and with Wine Staging 5.22 but it doesn’t start.

  /\         OS: Arch Linux 
 /  \        Kernel: 5.10.5-arch1-1 
/\   \       Uptime: 2m 

/ \ Packages: 810 (pacman)
/ , \ ----------------------
/ | | -\ DE: GNOME 3.38.2
/-’’ ‘’-\ Theme: Qogir-dark
Icons: Zafiro-icons
-------------------
GPU: NVIDIA GeForce GTX 1660
GPU Driver: NVIDIA 460.32.03
Memory: 1.04GiB / 15.62GiB
CPU: AMD Ryzen 5 2600 (12) @ 3.400GHz

EGL work fine with Lutris 0.5.8.1 and wine lutris-5.21. With wine lutris-6.0-RC don’t work not only EGL, but many games.

[System]
OS: Antergos Linux rolling n/a
Arch: x86_64
Kernel: 5.10.5-arch1-1
Desktop: GNOME
Display Server: x11

[CPU]
Vendor: GenuineIntel
Model: Intel® Core™ i5-4590 CPU @ 3.30GHz
Physical cores: 4
Logical cores: 4

[Memory]
RAM: 15.5 GB
Swap: 15.3 GB

[Graphics]
Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 1660/PCIe/SSE2
OpenGL Version: 4.6.0 NVIDIA 460.32.03
OpenGL Core: 4.6.0 NVIDIA 460.32.03
OpenGL ES: OpenGL ES 3.2 NVIDIA 460.32.03
Vulkan: Supported

Hello, I installed it with Lutris then I installed wine-staging 6.rc, it works nice.

I don’t know why but it actually started working with Wine Staging 5.22 when it didn’t before.