Back to the main site

Epic Games Launcher does not start, "No such file or directory"

As soon as I try to open the Epic Games Launcher I get a popup that says “[Errno 2] No such file or directory: ‘/dev/input/event3’”. This seems to be a relatively common issue, however none of the solutions I’ve found have helped me. I’ve already tried disabling Vulkan in the config and that didn’t change anything. Unfortunately there aren’t any logs from the launcher itself (and yes I enabled them in the config). Looking at the debug logs from Lutris, I think it might be some kind of issue with the Wine prefix? If anyone could help point me in the right direction I’d really appreciate it.

lutris --submit issue output: https://pastebin.com/54ZMfvN4
lutris -d output: https://pastebin.com/TZpgqEhS

Does it still happen if you install and use distro wine instead of the lutris one?

I’m not seeing this problem and don’t ever remember seeing it so it should be with something in particular about the way you’re doing it.

I went into config and changed the Wine version from lutris-6.1-3-x86_64 to System (6.9 (Staging)) and that had no effect. Also tried another re-installation and that didn’t do anything either.

There is an alternative called Heroic Games Launcher, from where you can launch games from Epic Store without the need to run the heavy windows app. I wonder if it will ever get integrated into Lutris as a launcher?

I have Heroic, it doesn’t work for me either. If I try to download anything on that it says “Game Imported” and then it refreshes my library and it stops the download. And anyway I was trying to get the actual Epic Games launcher working because I’m having difficulty connecting to my friends on Rocket League, which I think is caused by me not being signed in on the Epic Games launcher client (since I play the Steam version). They appear as “offline” to me and I appear as “offline” to them. I was hoping that having the launcher open would help mitigate the issue but I have no idea.

Well, I guess you just don’t have this? I really don’t know how you would go about getting it. It should just be there. But if not, in theory and possibly problematic you could try copying one of the others there in /dev/input/ and naming it to event3. If it solved the problem then you know that you can look to correct it better.

If it is there and its not finding it then I would think it should have to do with the paths that Lutris is obtaining so everything can be found that’s required. The first step there is to look into Lutris settings for Epic and the last tab should have two settings for that. But I think the Linux environment path is the other thing but I haven’t really had to do these things so not quite sure there.

dev/input/event3 is there, sorry I should have mentioned that I checked and it was present. I will take a look at the config and see what I can do