Epic Games fails to run after installing AMDGPU proprietary drivers (LLVM error?)

Previously, I was able to run GTA V via Epic Games on Lutris on my i7-4790k + nVIDIA 750 Ti based rig on fairly basic graphics settings without a hitch.

I’ve just upgraded my rig to this AMD Ryzen 9 3950X + RADEON based setup:

  • CPU: AMD Ryzen 9 3950X
  • GPU: XFX Radeon RX 590 Fatboy 8GB OC+ 1600MHz DDR5
  • Motherboard: ASUS TUF Gaming X570-Plus ATX
  • RAM: Corsair Vengeance RGB PRO 32GB (2 x 16GB) DDR4 3600MHz C18
  • PSU: Corsair VS650 650 W
  • Cooling: Corsair Hydro H100 x 240 mm Radiator Dual 120 mm PWM Fans Liquid CPU Cooler
  • Monitors: 2 x Dell P2416D-1 24-Inch, 2560x1440, primary monitor landscape, secondary portrait (rotated right),
  • Graphics drivers: Ellesmere / 4.6 Mesa 20.2.0
  • Linux Kernel: 5.4.0
  • OS: Linux Mint 19.3 (MATE)

Using the Open Source AMD drivers, I kept getting crashes when running graphic intensive programs. I could load Lutris, Epic Games and GTA V, but it would bomb out mid-game with a 3 minute hang followed by an automatic system reboot.

I installed the proprietary AMDGPU Linux drivers and now graphic stress tests like Unigine Valley run without crashing. However, I can no longer run Epic Games from Lutris.

I am seeing these errors in the console if I launch Lutris from a terminal:

Game is considered started.
esync: up and running.
Initial process has exited.
: CommandLine Error: Option 'help-list' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options
Game is considered exited.

vulkaninfo + lutris -d:
I’ve had to put both in the same paste due to this forum’s 2 link limit :roll_eyes:
lutris-d is down the bottom.

lutris --submit-issue:

I’ve tried with Linux kernels 5.4.0 and now 5.6.19. Same problem.

I would be very grateful if you can help me get GTA V running stable.
NB: downgrading to the Open Source drivers is not a viable option because of the catastrophic crashing that happens when running them.

1 Like

I have same issue, when there is start argument -openGL or start with disabled DXVK/VKD3D