Back to the main site

Epic Games browser login

I’m trying to play games that use the epic launcher, BL3 specifically, however, my epic account is via Google Login and when I click that option in the launcher it says to complete the login in your browser but no browser window appears so I cannot actually login. I’ve been googling and searching around but I can’t find any discussions as to what to do to get past this point. I tried the BL3 direct install and the Epic Games Launcher install in Lutris.
I made a test account for ‘email login’ and it works just fine. Epic doesn’t support account merging either, I looked into that option.

Hi, I sometimes also get that issue but after few attempts it login and it works.

Hi, iam facing same problem. Logs after i click Sign in with google:

gamemodeauto:
gamemodeauto:
gamemodeauto:
gamemodeauto:
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (failed to map segment from shared object): ignored.
need to run as root or suid

already tried install 32 bit libraries but it didn’t do the job.
Also tried to reinstall wine completely but it didn’t change outcome.