Elder Scrolls Online Network Error

I installed ESO following the instructions of [SOLVED] Elder Scrolls Online not working properly

I’m on a Inspiron 15 Dell Ubuntu 18.10, with a GeForce MX150, Nvidia driver 415.27, Vulkan 1.1.84, Wine version tkg-unity-4.1-x86_64 and Lutris

I was able to run the game. However, I have two problems: keyboard keys stuck and send several inputs (which is annoying, but still somewhat playable), and I have network errors.

Now, the disconnects are getting worse and I can’t login into the game; and when the login credentials go out, I get timeouts on the response. On the rare occasion I get into the game, I get random disconnects.

From the logs on Lutris I see this error:

ERROR:network_change_notifier_win.cc(143)] WSALookupServiceBegin failed with: 8

Any advice on how to diagnose or if possible fix the network error?

1 Like

Hi. Here might be a solve of youre problem - try to trace games ip addresses. Because i have same error in terminal while playing, but everything is fine. Playnig on Mint 19.1>gtx 850m(390.77 driver)>Lutris 0.4.23> wineHQ staging 4.2>dxvk 0.96>esync. But, i have problem with my internet provider - game doesn`t connect to launcher ip address (

I will do some debugging. The strange thing is that the game works on Windows with the same provider. So I was thinking that maybe it had something to do with how wine or the other programs connect to the network.

I was able to play some time, but now is getting worse. Random disconnects even at login time. I even get the loading screen, and then a disconnect.

So ? Are there any suggestion ?

Well, I have the same issue, I’ve run game consultant and it showed that the game cannot connect to launcher.bethesda.net . As I understood some kind of secure connection is needed.
I looked through some forums and there(here) I saw that you should install: webio winhttp and ie8 in winetricks, but that didn’t help me