EA App doesn't install correctly from the Lutris app

I’m new to Linux gaming, and linux in general, around a month or so, so I don’t know much about how to run games that aren’t already Linux-compatible on steam via proton or just by themselves, such as War Thunder and whatever.

How can I show the logs from the EA Installation that fails? Is there some type of command?

Hey, you can right click a game in the menu > show logs to check what causes the issue

If you can’t solve the issue try changing the settings, I have a post on my profile about Minecraft Dungeons game, consider trying out my settings.

Can I ask you what game are you trying to install?

Thank you for responding, I have already installed Need for Speed Rivals on Steam, but when I tried to install EA via the EXE from their site, since they don’t have any linux-compatible apps, it didn’t work, just opened for half a second then closed, same thing happening on Lutris. I will check logs when I get home, since I am away right now, will keep updated.

Sure! I recommend you trying to install the game using lutris installer and not via exe file

Click the plus icon to add a game and select search option, enter the name of your game and choose an installation method (I recommend wine) and follow the on-screen instructions. If game doesn’t launch this way try changing versions for runner options and install from different sources, if nothing works you can try installing from exe

In lutris, click + button on the title bar ->search for game → ea app → select the EA App and standard install.
Should install ok as long as you have added wine-ge8.22 in lutris (right hand pane->runners->click wine then the folder icon and install the top wine-ge version)

1 Like

The problem I have right now is installing the EA App, the game i can install from Lutris or Steam no worries.
It’s just that Lutris, even with wine-ge8.22 in runners, still doesn’t install the EA App, giving me at the end error code 768.
Also, the logs are empty when I right click on an app, any app, including the EA App icons that also show in a corner “Missing”.

You can try checking debug logs of a game, here is how to do this:

Right-click the game in lutris > Configure > Runner options > Output debugging info > Enabled. → Output of Lutris > Game > View last game’s log or run in in terminal and sent the output of terminal.
Source of this text

Debugging info provides more information and can be more useful in finding the issue

1 Like

read the pinned message in these forums on generating debug information in terminal using lutris -d

after launching lutris in terminal with the correct lutris -d command, redo the installation and copy all the text from the lutris -d onwards to paste bin.

And for the love of Dog, don’t enable debugging in the runner options - this is wine level debug info and will make it almost impossible to find an installation issue

1 Like

I installed Origin about a year ago. After that it was replaced by EA App and works until yesterday. It was crashed during updating process. I discovered that the reason is in this crash. If you already have files of this application but didn’t have a registry service registration it will fail. There is no EABackground service in registry. I added it and it started.
So now I have a workaround for lutris installation of EA.
Run lutris (0.5.16) and go here EA App - Lutris and install.
It will fail with the error something like ‘EAlauncher can’t be found’. There is no any files of this app in your wine prefix at this point. But this is the only process to prepare wine prefix. You can download EAinstaller in the beginning and use it as file in Lutris installation and on the next step.
I’am doing it under Xubuntu 22.04.3 and there is a wine 6.0.3 came with the package wine (this is important).
Next download EAappInstaller.exe and mono.
Install mono into wine prefix.

WINEPREFIX=~/Games_New/ea-app/ wine msiexec /i wine-mono-9.0.0-x86.msi
Otherwise next step will fail.

And now run

WINEPREFIX=~/Games_New/ea-app/ wine ~/Downloads/EAappInstaller.exe

Installer will start just press Let’s go. After that it will disapear.
Now you can start EA App from the Lutris.
I tried other versions of wine (9.0) from winehq but failed.
The problem is in the installer.
Another way is to install it in Win VM, copy EA directory and make registry files with tools like from Sysinternals by monitoring of registry changes made by app installation.
And add it to the wine registry by importing it with regedit.