DXVK dxgi file not found for every game (solved / PEBKAC)

Hello chaps !

EDIT : Nevermind, creating a specific wine prefix seems to be mandatory for DXVK to work properly, I did so and the game launches…

A case of maybe not RTFMing enough…

I’m currently running against a wall here running games without DXVK is alright, but everytime I enable it I get this

 [kuzko@localhost system32]$ lutris 
      WARNING  2018-07-27 19:10:06,661 [steam]:Importing Steam game %s but game might require additional configuration
      ERROR    2018-07-27 19:10:06,661 [steam]:Malformed config file: 
      INFO     2018-07-27 19:10:29,064 [runner]:Runtime disabled by system configuration
      WARNING  2018-07-27 19:10:29,066 [joypad]:python3-evdev not installed, controller support not available
      INFO     2018-07-27 19:10:29,076 [dxvk]:Replacing drive_c/windows/system32/dxgi with DXVK version
      ERROR    2018-07-27 19:10:29,077 [jobs]:Error while completing task <bound method wine.prelaunch of <lutris.runners.wine.wine object at 0x7fa4d45f5198>>: [Errno 2] No such file or directory: 'drive_c/windows/system32/dxgi.dll'
      <class 'FileNotFoundError'> [Errno 2] No such file or directory: 'drive_c/windows/system32/dxgi.dll'
        File "/usr/lib/python3.6/site-packages/lutris/util/jobs.py", line 29, in target
result = self.function(*args, **kwargs)
        File "/usr/lib/python3.6/site-packages/lutris/runners/wine.py", line 1011, in prelaunch
        File "/usr/lib/python3.6/site-packages/lutris/runners/wine.py", line 993, in toggle_dxvk
        File "/usr/lib/python3.6/site-packages/lutris/util/dxvk.py", line 125, in enable
self.enable_dxvk_dll(system_dir, dxvk_arch, dll)
        File "/usr/lib/python3.6/site-packages/lutris/util/dxvk.py", line 91, in enable_dxvk_dll
shutil.copy(dxvk_dll_path, wine_dll_path)
        File "/usr/lib64/python3.6/shutil.py", line 241, in copy
copyfile(src, dst, follow_symlinks=follow_symlinks)
        File "/usr/lib64/python3.6/shutil.py", line 121, in copyfile
with open(dst, 'wb') as fdst:

So what’s up with that? my RX480 on fedora 28 is capable of running vulkan (vkmark works).
I’m trying to setup shadow warrior 2.

Is there something more to do than install lutris, point to the windows installed game in the wine runner and enable dxvk 0.63 (manual version input)

kernel : 4.17.7-200.fc28.x86_64
mesa : Mesa 18.2.0-devel

any help would be appreciated.

Glad to know you solved the problem, but I don’t understand how you solved it.

The process for Wine games should be

  1. Pick a game on the website, press the install buton
  2. Wait for the installer to finish
  3. Personalize tweaks (DXVK/environment variables)
  4. Run the game

During that process, Lutris/Wine create a specific wineprefix for that game, by default under ~/Games/game-name.

Did you create a wineprefix and install a game inside your manually created wineprefix? That seems quite far-fetched.

Hmmm no, unless manually created, it doesn’t create anything…

Nope, but I previously used wine solo through the command line, and it of course created a default wine prefix…


I don’t know how you’re doing things, but Lutris’ scripts create wineprefixes when they run wine games. OR they install your game in its wineSteam prefix, if it’s Steam under wine.