Back to the main site

Dungeon Siege not starting anymore

I’ve been playing Dungeon Siege for a few days now, using the Steam installation.
Since the game is pretty old, I had to configure the resolution for the game to be much smaller than my regular one for it to start properly. Basically I had to fix it to the same resolution I chose in-game, otherwise the game window would cropped.
This worked well for a few days, but when I closed the game earlier today and restarted it later it wouldn’t start properly. Strangely enough it DOES start normally when I set the resolution to one smaller than the in-game one, but the display is obviously no good for playing.
With the appropriate settings, Lutris goes through the steam procedure, but as soon as the game would start I get a black screen and an error message about a “Video Initialization Failure”

I did not change any of the settings between the last time it worked and the first time it didn’t, though I fiddled around with them a bit since then to figure out what went wrong.

Update: After I rebooted my PC, everything works again.