DOSBOX run a linux app before launch

I am trying to run a linux software midi app (mt32emu-qt) before my game runs (colonization) so I get the nice mid.

I cannot find where to put this on Lutris. I have set up the runner to be dosbox etc.

Thank you!

1 Like

Dosbox-staging has MT32 built in

1 Like

wouldn’t you know, my Lutris was already using dosbox-staging… glad I found out before mess around trying to install it!
Thank you ComodoDragon, I am all set now!!!

Before I mark the question solved, do you know how can I run a linux app before dosbox on lutris?

There’s a pre-launch and a post-exit script option, write a bash script and point Lutris to it.

I created a bash script but nothing happens.

I named it and put this inside
#! /bin/sh

then made it executable via the GUI and in the console I can run it
and the musescore app runs

I then added the script in my game in Lutris, in the System Options / Pre-launch script
and the script does not run. Neither if I put it in the manual script

Anyone has any more ideas?

Try asking on reddit, there are more users than here.


First off, big shoutout to dr_costas for bringing up this topic. It’s great to see the community coming together to share their knowledge and experiences.

I totally get your frustration, dr_costas. Mixing and matching different software can sometimes be a bit tricky, but fear not! I’ve had a similar experience before. Back when I was diving into retro gaming, I wanted to get the perfect MIDI sound for my games too. What worked for me was setting up a custom launch script.

In your case, since you’re using Lutris and DOSBox, you might want to create a shell script that launches both the mt32emu-qt and your game. Make sure you’ve got the paths right and everything, and then point your Lutris runner to this script.

I’m not sure about Lutris specifics, but generally, this approach could do the trick.