DOOM problems

I gave up on trying to get DOOM running last year, but thought I’d try again. Still no luck though.

In my previous attempts (approx. 1 year ago) DOOM would try to start and give me an error. Now Lutris just says ‘Game has quit’ almost immediately after trying to start it.

I have no idea where to even start with troubleshooting this. All I have done to install is the install using the DOOM Lutris installer (vulkan verison), it has installed to my SteamWin folder, but not getting anything to start.
I have tried setting it to use system wine 3.8, and also 3.7 staging which Lutris installed. No different.

One thing I did try was just launching Steam in wine, and starting DOOM, at which point it just says I need a 64 bit windows.

Start Lutris using the terminal using “lutris -d” then right click on DOOM -> Configure -> Runner Options -> Debugging Output enbaled.

Run the game again, hopefully, the debugging output will be useful.

I’m struggling to understand this as I don’t really understand how WINE works. But I think something’s going wrong with the prefix.

Hmmm, I’m not sure what that user.reg file is. Can you do the same thing but try launch the game through steam?

You can ensure you’re using the same prefix by right clicking DOOM -> Confogure -> Runner Options -> Start Steam client

You have a malformed prefix. Delete the Steam/steamapps/common/DOOM/prefix folder.

There is no prefix in that location?

Your screenshot says there is.

If I navigate to that folder, only the game data is there. I created a prefix folder there to see what happens and it is removed as soon as I try to run Doom again.

Hi, I’m looking for some assistance getting Doom 2016 to run smoothly in Wine using Lutris on Manjaro. I’m having a strange issue – when I get in game, the performance starts to degrade and stutter after a moment. I can watch the CPU performance drop on my system monitor. It looks like little camel humps- the most irregular I have ever seen in a game. It is very smooth at first, then stutters to a completely unplayable state.

i74790k overclocked to 4.4ghz
gtx970 gpu
16gb ram
winestaging 3.10
driver 396.24

Any help is much appreciated I reeeally want to play this!

I’m having the same issue. I finally got Doom working about 2 weeks ago, and framerate starts at 60-70 and rapidly drops to about 10-20 with massive lag spikes.
I’ve tried with Adaptive sync, Vsync, No vsync, none of that makes a difference.

On the wine reddit someone said there was a Doom update a couple months ago adding Razer Chroma support, and ever since then the game has been unplayable.

I get massive frame drops unless I launch the game from steam

How do you manage that? When I’ve tried to launch from steam it just tells me I need a 64 bit version of Windows.

are you running a 64bit version of wine in your wine steam runner configuration?
I didn’t do anything to make it work I just selected a 64 bit version of wine for my wine steam runner staging-3.10-x86_64

Hey everyone, my issue is fixed! I also posted over to r/linux_gaming on Reddit and someone suggested killing Lutris with the terminal after launching the game and it worked!

So after playing a few hours, closing the game, and going back into it, I now have a new issue out of nowhere I can’t seem to fix no matter how many settings I toggle. The mouse is hitching for half of a second when looking around. Has anyone else had this same issue? Please help!