Doom fails to start due fatal error

I’ve installed Doom (2016) through the script on Lutris page. Now it doesn’t start, giving a fatal error instead.

I’ve done a search and seen it suggested that this is due to the game starting with openGL instead of Vulkan. But I haven’t seen anyone suggest a solution.

I’m running wine 2.17, but I don’t know anything about wine really. This is the first time I’ve tried to play non-native games.

This is the error below:

Configured log listener print-redirect tags
Added structured log listener print-redirect
Added structured log listener mp-cloud-gobbler
2017-10-01T09:04:05.869+11:00 LOG: Process started
idBNetLoggerRESTReferences: Failed to parse: /v3/collect_logdata
Added structured log listener bnet-logger
Winsock Initialized
------ Initializing File System ------
Current search path:
- C:/users/chris/Saved Games/id Software/DOOM/base/
- Z:/run/media/chris/SSD512/SteamWine/steamapps/common/DOOM/base/
------ File System initialized.
------ Command Line ------
2017-10-01T09:04:05.876+11:00 LOG: Command Line: Z:\run\media\chris\SSD512\SteamWine\steamapps\common\DOOM\DOOMx64.exe
------ CPU Information ------
1 CPU package, 12 physical cores, 12 logical cores
3200 MHz AMD CPU with MMX & SSE & SSE2 & SSE3 & SSSE3 & SSE41 & SSE42 & AVX
65536 kB 1st level cache, 524288 kB 2nd level cache, 8388608 kB 3rd level cache
16048 MB System Memory
initializing resource container gameresources.resources
idLib::SetProduction( PROD_PRODUCTION )
------- Initializing renderSystem --------
—registered window class
—registered fake window class
—registered context window class
X…WGL_EXT_swap_control_tear not found
unknown error: 0x0
FATAL ERROR: wglCreateContextAttribsARB failed
Dumped console text to C:\users\chris\Saved Games\id Software\DOOM\base\ErrorLog_10-01-2017__09-04-06am.txt.

Shutting down OpenGL subsystem

FATAL ERROR: wglCreateContextAttribsARB failed

It looks like your drivers don’t support the OpenGL extensions required by Doom. You might have more luck with Vulkan, but I have no idea how to switch to Vulkan without starting the game first. (There’s probably a command line switch or something)

I updated the doom install scripts about a day or two ago. there are now two seperate ones for opengl and vulkan as well as some minor install updates, and using latest wine with no issues.

Thanks mate. I’ll try installing it again this week.

Just finished installing with the vulkan script.
Lutris states ‘Preparing to launch’ then ‘Game has quit’. Steam won’t even launch.

I tried removing the prefix ~/Games/doom-steam-vulkan and now Steam starts, dialog box says that Doom is launching, then disappears and nothing happens.
Eventually Steam closes and Lutris says ‘Game has quit’.

It’s definitely a frustrating piece.

try disabling the process monitor in the system tab for doom in lutris

Witht eh process monitor disabled, Lutris just says ‘Playing DOOM’, but still no game. Steam flashes up ‘Preparing to launch Doom’, but nothing happens and there doesn’t seem to be any indication that anything is happening.

Does Doom not work with AMD cards?

I guess if I want to play this game I’m going to need to installa windows partition.
Thanks anyway.

It works fine with AMD. I run it on an RX vega card, which means its more than capable on other amd cards. I’ve also run it on several nvidia cards. Furthermore vulkan and opengl both run with native rendering in wine which means no performance lost compared to windows. Do you have vulkan packages for your gpu installed on your distro?

There are a few things for you to check:

  1. Right click doom in lutris>configure>game options
    make sure the arguments says:
    +r_renderapi 1

  2. Right click doom in lutris>wine configuration>Applications
    Check to see if Steam.exe is listed there. If it is, check to see that Steam.exe is set to Windows XP for the windows version. If it’s not, add it. (Click add application, type Steam.exe, click open, then click Steam.exe under Default Settings, and select Windows XP from the drop down and press ok.)

Then try to run the game.

I did notice it seems to stay on “Preparing to launch doom” for a while, but it does eventually work in both opengl and vulkan

EDIT: Looks like the opengl version has the same problem as the wolfenstein games: wglCreateContextAttribsARB failed

You’ll want to make sure it’s running in vulkan:
Right click DOOM in lutris>configure>game options, check “do not launch game, only open steam”

Then run it in lutris. It will open steam, In your steam library, right click DOOM>properties>General
click set launch options and add:
+r_renderapi 1

close, then close steam then go back into doom config in lutris and uncheck “do not launch game, only open steam”

this should resolve the issue for amd

The native Vulkan support was one of the reasons why I got Lutris, it sounded like this game works flawlessly but no linux version! ID software linux ports have always worked great for me.

I have tried all of those things except one:
Step 2 - Right click Doom in Lutris>wine configuration>Application.
I can’t get this one. All my other games when I click ‘wine confuration’ it gives the options immediately. But with Doom, nothing happens. There is no wine configuration for Doom on this machine as far as I can tell.

I have the vulkan packages for amdgpu installed.
I have the +r_renderapi 1 set in the Doom launch options in Steam.

if you have the renderapi option set in steam you can ignore the lutris option. it should run, just let “preparing to launch doom” do its thing