Doom 3 BFG Edition not launching

I have it installed with the RBDoom3-BFG source port and it quits right after I start it up on Lutris.

Two things that can help troubleshoot this problem a lot

  • Please state what Lutris installer you used and if it ran properly from start to finish
  • Please run Lutris in a terminal when trying to launch the game.

Open a terminal anywhere, open lutris by typing “lutris”. The terminal now shall serve as debug information for your game. If your game quits really quickly, there should be an error message somewhere in your terminal.

I used the native installer which uses game data from Steam which installed properly.
Also, I ran it from the termnal and this is what came up when I ran Doom 3 BFG Edition:

/home/joao/Games/doom-3-bfg-edition/RBDoom3BFG: error while loading shared libraries: cannot open shared object file: No such file or directory

That’s better. That suggests you don’t have libavodec version 54 in your system.

That can mean one of two things:

  • You don’t have libavcodec at all, which you can figure with your package manager
  • you have a higher version of libavcodec.

I’m on Linux Mint 19, which means Ubuntu 18.04 and my libavcodec is on v57.

Since I don’t own that game, I can’t test if it’s THAT dumb and looks for that specific version of libavcodec, but it’s a good lead.

I’m on Ubuntu 18.04 with libavcodec-extra57 installed the game runs without error

Do you know any command lines for installing it?

it’s been over a month since I installed it ; if I recall, I used the doom-3-bfg-edition-native-steam-data-64 install script

sudo apt install libavcodec57

installs libavcodec57. You should check if you have any version first

apt list libavcodec*

If everything’s alright, you should be able to run the game without reinstalling.

Still crashing :confused:

same error message?

I have libavcodec-extra57 not libavcodec57

apt-cache showpkg libavcodec-extra57 shows the reverse dependency for rbdoom3bfg

Yep, still the same message :cry:

Can you show logs and error messages? (or at least copy them)

It’s hard to believe you have all the required libraries and the game still refuses to work. Please also mention your linux distribution and linux kernel. The latter can be obtained with

uname -r

in a terminal. You can get it to play :open_mouth: don’t give up!

My distro is Lubuntu and my kernel is 4.15.0-24-generic.

Also here’s the log of when I launched Lutris within the terminal:
joao@joao-MS-7917:~$ lutris

(lutris:4620): dbind-WARNING **: 10:50:52.649: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
INFO 2018-07-18 10:50:52,938 [xdg]:Found desktop game “GZDoom” (app: gzdoom, slug: gzdoom)
INFO 2018-07-18 10:50:53,529 [lutriswindow]:Connected to as DoomNukem69
/home/joao/Games/doom-3-bfg-edition/RBDoom3BFG: error while loading shared libraries: cannot open shared object file: No such file or directory

OK, it’s still pretty odd. Lubuntu instead of Ubuntu may be a problem because being lightweight means trying not to get anything extra.

What is more strange to me is that

sudo apt install libavcodec-extra57

does not solve your problem. You do have it installed and all, right? What output do you get when you execute this command? (with the asterisk *)

apt list libavcodec*

I had the same problem. Will experiment a bit more when I have time. the libavcodec version I have is;

I have it installed and also when I wrote “apt list libavcodec*” the output was:
Listing… Done
libavcodec-dev/bionic,now 7:3.4.2-2 amd64 [installed]
libavcodec-extra/bionic,bionic,now 7:3.4.2-2 all [installed]
libavcodec-extra57/bionic,now 7:3.4.2-2 amd64 [installed,automatic]
libavcodec57/bionic 7:3.4.2-2 amd64

You can try

sudo apt get libavcodec57

since you don’t have that package installed. If that doesn’t solve the problem, I’m clueless.

run ldd /home/joao/Games/doom-3-bfg-edition/RBDoom3BFG look for missing libraries

I ran it and it says: => not found => not found => not found => not found

ah, found the discrepancies I built RBDOOM-3-BFG I don’t exactly recall why it could have been because of the broken dependency. – sorry for the confusion