Back to the main site

DirectX 8

I have a game from 2001 that requires DirectX 8. Is it possible to get DirectX 8 working with Lutris? Or is the game just too old?

As you didn’t state the name of the game the only thing I’d suggest is looking at the app database on winehq.

It is actually a requirement, or does the game only know about DirectX 8?
If you’re using Lutris runners or a custom wineprefix, and if the game is starting up and complaining about DirectX, then it might just not be detecting any DirectX. Have you tried using winetricks to push in DX9 support? See how it goes.

Most games I knew that needed DX 6+, run under DX 9 without major issues. It used to be certain early DX games that were “only” compatible with older versions, needing directDraw, directShow etc.

Yeah, I left it out because I was thought I was just asking about a setting.Though, After reading XDqAtG5A8g’s explaination, I’m starting to realize that it might not be “set in stone” requirement. The game is Spongebob Squarepants: Operation Krabby Patty.

Well, it’s just that the install screen had a thing about installing DirectX 8 , and at one point in the installation it asks about installing it.
DX8%20Reference%201 DX8%20Reference%202

I just tried it with DX9VK but without reinstalling, but it didn’t help. Instead, I received the following error message:
Screenshot_2019-11-21_12-38-18

Edit: Wine does support DX8, so you can let it install its dx8 redist if you want - however, installers that were made a long time ago may break like above.

Double Edit: Apologies. You came here for support, and I’m making an assumption about how much WINE you know. I’d recommend trying it in a clean prefix first, so you don’t end up breaking your .wine with odd settings.

Create a new, clean 32bit wine prefix: -
$ WINEARCH=win32 WINEPREFIX=~/.my32bitgame wineboot

… you can check ~/.my32bitgame/drive_c for Windows-like directory structure.

Use winecfg to set the OS version to something near what your game needs (applications tab), and any extra drives you might need, e.g. mapping the CDROM: -
$ winecfg

Run explorer and your installer: -
$ wine explorer

“Bad windows version” :slight_smile: - you might want to use winecfg/winetricks to re-set the version to something older - install packages are probably complaining that they don’t know what to do.

As the original responder posted, have you checked the WINE appdb at all? It might have some tips there, or at least give you an idea if it works.

A lot of those really old games just work. You should just ignore the messages about installing things like DirectX8, then try running it. Don’t use things like dxvk or dx9vk, those are for more recent versions of DirectX. Vanilla wine will run most of those really old games/apps without the need for installing anything extra into your wine prefix, using just your system wine.