Back to the main site

Did Win11 break DXVK support?

I have Lutris installed and working under Ubuntu 20. I had it all setup to load a DX11 game installed under Windows 10, and it worked just fine for years (successfully enabling DirectX support using DXVK.)

Last week I “upgraded” to Windows 11 and now suddenly DXVK support no longer works (the game giving a “DirectX Not Found” error on launch.)

Nothing wrong with the game. Loads just fine in OpenGL mode, and likewise works fine in Windows.

I’m wondering if something may have changed that makes Lutris unable to locate the necessary DX libraries upon moving to Win11?

PS: I tried to create a Lutris error report as requested by the forum, but the Terminal is unable to find Lutris using the provided Command Line.

That doesn’t really make sense, as it’s not loading DirectX libraries and friends from your Windows installation (it’s using Wine and DXVK). You’re just running it in place on the Windows filesystem.

I would check your DXVK settings in Lutris. In Runner Options of the game, enable Advanced view so you can see the DXVK field. Make sure it’s set to a valid version (not “Manual” or a non-existent one). For example, 1.9.2L

Thanks for the reply.

I tried every alternative Advanced setting there is and nothing I tried could get DXVK support working again.

I’m not sure what happened if it’s not Win11. Only possibility I can think of is my C: drive (where I assume all the DirectX files lie) had to be converted from MBF to GPT in order to install the new OS.

I’ve never done that, run the games from a Windows filesystem, but if you’re able to launch the game without DXVK (in “OpenGL mode”) I can’t see it being filesystem related and if you’re accessing it, you obviously can mount GPT Windows partitions.

Good point.

I think I may need to reinstall DXVK and I’m not sure how to do that.

Lutris maintains its own DXVK implementations in ~/.local/share/lutris/runtimes/dxvk in your home directory. In the wine prefixes, according to which version is configured in Runner Options, it creates symbolic links to the dll files. For example, in windows/system32

d3d11.dll → /home/grogan/.local/share/lutris/runtime/dxvk/v1.9.2L-3e64e1b/x64/d3d11.dll

Edit: Note that this SILLY forum script is stripping things from that path. There’s an x64 directory in there.

and the same for windows/syswow64 (the 32 bit dlls)

If you were to drop another version in ~/.local/share/lutris/runtimes/dxvk and select it in Runner Options, when the wine prefix gets updated (either by launching the game or going to “configure wine prefix”) new symlinks should get created.

I would THINK (but I haven’t tried it) that if you deleted a dxvk version that Lutris would re-download it again when it does the runtime update check at startup. Maybe rename one (e.g. v1.9.2L-3e64e1b) out of the way and see if Lutris will re-download it according to the versions you are supposed to have in the dxvk-versions file)

Hmm. I’ve tried setting Lutris to use different versions of DXVK, but it didn’t help. And just now I tried reinstalling DXVK, which likewise didn’t help. Here is the error message I’m getting (I know it says DX8, but the program is actually using DX11 to load a custom dll. Worked fine for years.):

Screenshot from 2021-10-14 06-38-08

Follow-up: A reinstall of DXVK didn’t work.

I was never able to get DX9 support to work (even when DX11 support was working.)

Anyone else experiencing issues?