Did anyone manage to make For Honor work?

The game installs properly, but when I launch it, it goes like this: Steam, Uplay and then the launch of the actual game, which never goes beyond the initial picture with three warriors - it disappears after a while and then nothing.

Nope, it’s one of the game on the Hall of Shame

Thanks for the reply. I actually managed to get to the seizure warning screen by changing runners, but no further.

I can arrive to this screen

But after that, when is connecting servers the game crashes. I read something about ports, I tried, but I’m not sure why it fails. Any suggestion?

I had FH. Starter Edition.

*The initial video is corrupted, I skip it.

*I have the nvidia drive 415.22 (the last) and dxvk disabled (I tried enabled and disabled).
** Nvidia 1050ti

I get the same result. At that screen it crashes for some reason. Had no luck trying in offline mode and disabling the screen overlay. Also tried installing vcrun2015 & vcrun2012 (though i’d just try it) and also XACT but no luck. Also tried turning off my internet connection to see what happens because it crashes at contacting servers but that also didn’t work :^)

Installed Uplay using lutris and from that I installed steam and for honor (starter edition) automatically.

The video isn’t corrupted for me though.

GTX 1070, nvidia 415.25
DXVK 0.95
Wine staging 4.0-rc7
4.18.0-13-generic Ubuntu 18.10

If anyone feels like it, you can ask for logs. Haven’t included them for now since it’s already in the hall of shame.