Diablo IV No Sound

This is really weird. I played Diablo IV yesterday during the day and everything worked fine. Last night I opened up Lutris, launched Battle.net client, ran Diablo IV but no sound. I check all the sound settings in game with no help. I checked the sound in KDE and its set on the right device. Sound works on everything else. Exited D4 and launched D3 and I have sound in D3, back to D4 no sound.

In troubleshooting today I noticed that when I launch D3, click the sound icon in KDE, click the application tab I see Diablo 3.exe as using sound. When I play D4 there’s nothing under applications. I have no idea if that has anything to do with the situation but it could be a symptom ?

In game, I tried “System Device” and “pulseaudio” for sound devices. No difference.
Uninstalled the game and reinstalled. No difference.
Works fine in Winduhs. (Dual Boot)

I fell like this is a me problem and not a Lutris problem. (Could be wrong though.)
Any help would be appreciated.


Fedora 37 KDE Plasma 5.27.4
Kernel: 6.4.4-100.fc37.x86_64
CPU: AMD Ryzen 7 5700X (16) @ 3.400GHz
GPU: AMD ATI Radeon RX 5600 OEM/5600 XT / 5700/5700 XT
Memory: 7790MiB / 48068MiB

Never mind. It was a me problem. reinstalled battle.net client, then game. Works fine now.

1 Like