Diablo IV crash after starting the game

I’m new to the forurm.
I’m using lutris to play diablo but the game crashes the PC a few seconds after the game starts.
I can’t found out what is happening.
Here are some information about my configuration:

me@cb:~/Téléchargements$  inxi -Fxxxrz
  Kernel: 5.15.0-113-generic x86_64 bits: 64 compiler: gcc v: 11.4.0
    Desktop: Cinnamon 6.0.4 tk: GTK 3.24.33 info: latte-dock wm: muffin vt: 7
    dm: LightDM 1.30.0 Distro: Linux Mint 21.3 Virginia
    base: Ubuntu 22.04 jammy
  Type: Desktop System: Micro-Star product: MS-7C02 v: 3.0
    serial: <superuser required>
  Mobo: Micro-Star model: B450 TOMAHAWK MAX II (MS-7C02) v: 3.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: H.C0
    date: 10/14/2023
  Device-1: hidpp_battery_0
    model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: Discharging
  Info: 6-core model: AMD Ryzen 5 PRO 4650G with Radeon Graphics bits: 64
    type: MT MCP smt: enabled arch: Zen 2 rev: 1 cache: L1: 384 KiB L2: 3 MiB
    L3: 8 MiB
  Speed (MHz): avg: 1567 high: 3492 min/max: 1400/3700 boost: enabled
    cores: 1: 3492 2: 1340 3: 1397 4: 1397 5: 1397 6: 1397 7: 1400 8: 1397
    9: 1397 10: 1397 11: 1397 12: 1397 bogomips: 88635
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] driver: amdgpu
    v: 6.7.0 pcie: speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1
    empty: DP-1, DP-2, DP-3, Writeback-1 bus-ID: 12:00.0 chip-ID: 1002:73df
    class-ID: 0300

Running in debug gives poor information
flatpak run net.lutris.Lutris -d

Gtk-Message: 19:45:03.962: Failed to load module "xapp-gtk3-module"
2024-07-07 19:45:04,040: Command 'fluidsynth' not found on your system

can I provide some more information for any help?

One of the biggest crashes in Diablo 4 Season 4 has affected those using an Nvidia 40-series GPU. Blizzard has officially acknowledged this problem, and a possible fix is to disable Frame Generation for the time being. This can be done directly from game zone the official Nvidia GeForce Experience App. Although the game will still crash after reaching the login screen in our experience, we were able to make it past the initial title screen with this adjustment. Some users have reported that selecting the Run as administrator option on the app, then selecting Diablo 4 for them has helped them start the game.

One thing you can try ahead of what I posted below is find the file LocalPrefs.txt in your D4 prefix (install folders) and change the “Adapter” value from “0” to “1” save and launch again from lutris

  1. In Software Update app, in the menus somewhere is a kernel options - find the newest kernel there and install it - your 6700xt will thank you for the better driver performance

The issue you have is caused by the igpu in your cpu, the 6700xt and how the Blizzard app handles which device to use to launch the game on. On Mint, I would install the 0.5.16 version of lutris (from the Ubuntu downloads link on lutris.net - right click open with gdebi after download) and then install the wine and driver dependencies from the wiki pages on the git site (or look for my other posts here where I link them) - for the drivers, kisak will work fine but remember when you upgrade to the new Mint in a few weeks/next month to use Remove foreign packages to downgrade these to the Mint repo versions to allow for an easy upgrade, and don’t add the kisak back as the new Mint has a good solid mesa version as default.

The new install of lutris from the deb file should see your existing installed games, so the only thing you need to fix is the launch gpu by:
three lines on lutris title bar → preferences → global options → enable Advanced at the top → Multi-GPU section - set the vulkan ICD loader field to RADV 6700xt - if the field is called GPU, it means you are using 0.5.17 lutris - you can try setting this to the 6700xt, but in my experience, unless you enable the Wayland option at logon, battle.net will not launch.

Thank for your answer,
I don’t think to be in such a case as i’m not using Nvideo Graohix=cs but AMD One.

Hello OJ1,

Thanks for you advices.
I found the file LocalPrefs.txt in the directory ~/Games/battlenet/drive_c/users/steamuser/Documents/Diablo IV. Is it the one to change?
I’m using now the 0.5.17 of lutris (flatpak). Do you mean I need to downgrade to version 0.5.16?

I think (but may be I’am wrong) that I don’t have a problem because of my iGPU because I disable the igpu in the BIOS.
As you could see, the title bar → preferences → global options → enable Advanced at the top →
The section is set to GPU and the field is grayed to auto (so in think it uses my graphic 6700).
I don’t have in this section vulkan ICD loader field.

I with give a try to update the kernel to the last one ( I’m now using the
I never done this before :cold_sweat:, but I will try and give you a feeback.

@OJ1 kernel update done
~$ uname -r
The game still crashes at start

Read the pinned message in the forums here - the command to launch flatpak lutris is flatpak run net.lutris.Lutris -d (no quotes of course) - get the output and get that back here per the instructions - I will have a look

Hi @OJ1,
Here is the logs you asked for.
flatpak run net.lutris.Lutris -d

and an other log file:

[0710/190338.885:ERROR:network_change_notifier_win.cc(143)] WSALookupServiceBegin failed with: 0
[0710/190338.937:ERROR:network_sandbox.cc(302)] Failed to grant sandbox access to cache directory C:\users\cb\AppData\Local\Battle.net\BrowserCaches\common\Cache\Cache_Data: Procédure introuvable. (0x7F)
[0710/190338.938:ERROR:network_sandbox.cc(396)] Failed to grant sandbox access to network context data directory C:\users\cb\AppData\Local\Battle.net\BrowserCaches\common\Network: Succès. (0x0)
[0710/190338.940:ERROR:network_service_instance_impl.cc(270)] Encountered error while migrating network context data or granting sandbox access for C:\users\cb\AppData\Local\Battle.net\BrowserCaches\common\Network. Result: 6: Succès. (0x0)
[0710/190339.539:ERROR:network_change_notifier_win.cc(143)] WSALookupServiceBegin failed with: 0
[0710/190339.558:ERROR:dxva_video_decode_accelerator_win.cc(1459)] DXVAVDA fatal error: could not LoadLibrary: msvproc.dll: Module introuvable. (0x7E)

Note: I found the logs in a file in the folder “~/Games/battlenet/drive_c/users/cb/AppData/Local/Battle.net/Logs” because the “show logs” in the menu is empty.

…and the submit issue:

flatpak run net.lutris.Lutris --submit-issue
Gtk-Message: 19:32:10.201: Failed to load module "xapp-gtk3-module"
2024-07-10 19:32:10,351: Command 'fluidsynth' not found on your system
2024-07-10 19:32:10,982: Starting Lutris 0.5.17
MESA: error: Use of VkSurfacePresentModeCompatibilityEXT without a VkSurfacePresentModeEXT set. This is an application bug.
2024-07-10 19:32:11,036: AMD Radeon RX 6700 XT (1002:73df 1002:0e36 amdgpu) Driver 24.1.1
2024-07-10 19:38:07,585: Shutting down Lutris


Hi @OJ1 ,
Hi hope you’re well.
Are the logs I sent enough to investigate around my issue?

sorry - have been out sick for a week

Something is definitely broken there - you may need to head to the lutris discord server or install the native lutris app from the downloads section → Ubuntu → git page - don’t use the repo version, it is out of date. You will also need to check the wiki pages on git for the wine dependencies and drivers (ignore the Mint warning on the drivers if you are using 21.3, it was added because of an issue with Mint 21.0 and .1)

Hi @OJ1,
Thanks again for your help.
I had already have installed Lutris v0.5.17 from Release v0.5.17 · lutris/lutris · GitHub.
I had experienced the same problem.
But I didn’t take care about the wine dependencies and drivers , as installing apt from deb file was also installing wineHQ.
I will pay attention to the Wiki for wine dependencies and drivers.