Back to the main site

Diablo 1 (GOG Vanilla) won't go past launcher

Hello,
I’m running Lutris 0.5.8.3 on Manjaro with nvidia drivers 460.39. I installed Diablo 1 with “GOG - Hellfire - Vanilla version” installer, which ran fine. I launch the game and get the menu with Diablo, Diablo (Classic), Hellfire, Video Settings, Exit . Whichever of the first three options I click on, the launcher simply exits.

dmesg is full of

[Fri Feb 19 22:12:17 2021] sr 2:0:0:0: [sr0] tag#12 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE cmd_age=93s
[Fri Feb 19 22:12:17 2021] sr 2:0:0:0: [sr0] tag#12 Sense Key : Not Ready [current] 
[Fri Feb 19 22:12:17 2021] sr 2:0:0:0: [sr0] tag#12 Add. Sense: Medium not present - tray closed
[Fri Feb 19 22:12:17 2021] sr 2:0:0:0: [sr0] tag#12 CDB: Read(10) 28 00 00 00 00 00 00 00 08 00
[Fri Feb 19 22:12:17 2021] blk_update_request: I/O error, dev sr0, sector 0 op 0x0:(READ) flags 0x80700 phys_seg 4 prio class 0
[Fri Feb 19 22:12:17 2021] sr 2:0:0:0: [sr0] tag#5 unaligned transfer

and game logs are showing:

Running /home/XXX/.local/share/lutris/runners/wine/lutris-6.0-x86_64/bin/wine /home/XXX/Games/diablo/drive_c/GOG Games/Diablo/dx/DiabloLauncher.exe
Initial process has started with pid 31302
Start monitoring process.
wineserver: using server-side synchronization.
wine: configuration in L"/home/XXX/Games/diablo" has been updated.
Initial process has exited (return code: 0)
wine: Unhandled page fault on read access to 000000DC at address 180F44D3 (thread 01c8), starting debugger...
Monitored process exited.
All monitored processes have exited.
Exit with returncode 0

I also tried wine5 instead of 6, same result.

Instead of running DiabloLauncher.exe, I tried:
~/.local/share/lutris/runners/wine/lutris-6.0-x86_64/bin/wine "~/Games/diablo/drive_c/GOG Games/Diablo/Diablo.exe"

Got the resolution change (which is a good sign), and a popup asking me for the CD. The output on the console was:

wineserver: using server-side synchronization.
002c:fixme:winediag:LdrInitializeThunk Wine TkG (staging) 6.0 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please don't report bugs about it on winehq.org and use https://github.com/Frogging-Family/wine-tkg-git/issues instead.
00f8:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
00f8:fixme:ddraw:ddraw7_WaitForVerticalBlank iface 00764CE0, flags 0x1, event 00000000 stub!
wine: Read access denied for device L"\\??\\Z:\\", FS volume label and serial are not available.
wine: Read access denied for device L"\\??\\Z:\\", FS volume label and serial are not available.
wine: Read access denied for device L"\\??\\Z:\\", FS volume label and serial are not available.

When I try launching Diablo.exe from the dx folder, the resolution changes, I hear the sound of the Blizzard logo but I still see my desktop. The game then crashes (and my screen stays in 640x480) and wine dumps:

Unhandled exception: page fault on read access to 0x02a74000 in 32-bit code (0x1502e284).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:1502e284 ESP:0031f3a0 EBP:02a74000 EFLAGS:00010297(  R- --  I S -A-P-C)
 EAX:0031f3f8 EBX:000000fa ECX:0000025d EDX:0000008f
 ESI:000001e5 EDI:00000001
Stack dump:
0x0031f3a0:  0031f450 028c0010 0000025d 00000000
0x0031f3b0:  000093f7 00000000 02a5ec28 1502e148
0x0031f3c0:  000000d8 00000008 0000025d 0031f3f8
0x0031f3d0:  010000fa 00000000 00000000 0031f410
0x0031f3e0:  0031f3f4 ffffffff ffffffff 000000d8
0x0031f3f0:  0031f4ac 00000000 00000000 00000000
Backtrace:
=>0 0x1502e284 432+0x2e4() in storm (0x02a74000)
0x1502e284 432+0x2e4 in storm: movb	0x0(%ebp),%cl
Modules:
Module	Address			Debug info	Name (37 modules)
PE	  400000-  6b2000	Deferred        diablo
PE	 20d0000- 20ea000	Deferred        smackw32
PE	 20f0000- 21ab000	Deferred        winmm
PE	10000000-1004b000	Deferred        diabloui
PE	15000000-15045000	Export          storm
PE	61740000-61783000	Deferred        advapi32
PE	62fc0000-6304d000	Deferred        rpcrt4
PE	63480000-6348d000	Deferred        version
PE	63bc0000-63bd9000	Deferred        shcore
PE	64a40000-64a94000	Deferred        shlwapi
PE	64ec0000-64fef000	Deferred        oleaut32
PE	67d40000-67d6b000	Deferred        mmdevapi
PE	682c0000-6831d000	Deferred        dsound
PE	68500000-6855a000	Deferred        combase
PE	68700000-6872e000	Deferred        uxtheme
PE	68e00000-68e12000	Deferred        aclui
PE	697c0000-69d0b000	Deferred        ddraw
PE	6a400000-6a532000	Deferred        ole32
PE	6bc00000-6bc2c000	Deferred        sechost
PE	6bcc0000-6bd41000	Deferred        setupapi
PE	6c9c0000-6cb19000	Deferred        gdi32
PE	6cc40000-6cd9f000	Deferred        comctl32
PE	6d1c0000-6d258000	Deferred        crtdll
PE	6ed00000-6ef15000	Deferred        user32
PE	70b40000-70c11000	Deferred        ucrtbase
PE	70d00000-70e08000	Deferred        comdlg32
PE	71200000-7121b000	Deferred        imm32
PE	7a840000-7a844000	Deferred        opengl32
PE	7b000000-7b0e9000	Deferred        kernelbase
PE	7b600000-7b819000	Deferred        kernel32
PE	7bc00000-7bca4000	Deferred        ntdll
PE	7d8f0000-7d8f4000	Deferred        winex11
PE	7df20000-7df2b000	Deferred        winspool
PE	7dfa0000-7e896000	Deferred        shell32
PE	7e9f0000-7e9f3000	Deferred        wow64cpu
PE	f5920000-f5924000	Deferred        wined3d
PE	f7a40000-f7a43000	Deferred        winepulse
Threads:
process  tid      prio (all id:s are in hex)
00000038 services.exe
	0000003c    0
	00000040    0
	0000004c    0
	00000070    0
	00000088    0
	00000094    0
	000000c0    0
	000000d4    0
00000044 winedevice.exe
	00000048    0
	00000054    0
	00000058    0
	0000005c    0
00000060 plugplay.exe
	00000064    0
	00000074    0
	00000078    0
	0000007c    0
	0000009c    0
00000080 winedevice.exe
	00000084    0
	0000008c    0
	00000090    0
	00000098    0
	000000a4    0
000000b8 svchost.exe
	000000bc    0
	000000c4    0
	000000c8    0
000000cc rpcss.exe
	000000d0    0
	000000d8    0
	000000dc    0
	000000e0    0
	000000e4    0
	00000138    0
	0000022c    0
00000128 explorer.exe
	0000012c    0
	00000130    0
	00000134    0
0000020c (D) Z:\home\XXX\Games\diablo\drive_c\GOG Games\Diablo\dx\Diablo.exe
	["Z:\home\XXX\Games\diablo\drive_c\GOG Games\Diablo\dx\Diablo.exe"]
	00000210    0 <==
	00000234    0
	00000238    0
	0000023c   15
	00000240    0
	00000244   15
	00000248    1
	00000258    0
00000214 conhost.exe
	00000218    0
0000021c explorer.exe
	00000220    0
	00000224    0
	00000228    0
System information:
    Wine build: wine-6.0.r0.g2414b1da ( TkG Staging Esync Fsync )
    Platform: i386 (WOW64)
    Version: Windows 10
    Host system: Linux
    Host version: 5.9.16-1-MANJARO

Any help will be appreciated! :slight_smile: