Desktop integration shortcuts

Hello! :slight_smile:

My wine documents are protected elsewhere, so I can clean prefixes at ease.

However, Lutris/Winesteam is erasing my shortcuts settings, which is a pain.
Is this behavior intended? If yes, there is any way to disable it?

I did tried using symlinks, but they are also overriden.


Sorry for my English. :kissing_heart:

Lutris removes any links to “My Documents” folders in order to keep everything in the same location and avoid having game files all over your Documents folder in your Linux OS.

Are you trying to do something else?

1 Like

So sorry for the late reply.

I’m trying to do exactly that, lol
Would be really nice to be able to setup a folder outside lutris prefix.

I have a dedicate directory for “Documents”, so Steam does not have to sync all save games every time a prefix wipe is required, plus saves me time from backing them up manually. It also helps saving space and bandwidth, since with various prefixes you will have steam downloading all your saves for each one of them (I use a single SteamLibrary for quick deployment, so steam will sync all my games).

I understand why the default behavior is forced, but please think about a switch option or something like that.

Thanks for your work. :slight_smile:

Another user has expressed interest in having this behavior made optional. This is something we can consider since it’s very easy to implement. I’ll see if we can ship that in 0.4.8 or 0.4.9


I’m also interested in making this optional, since cause of how Lutris handles the custom prefixes for Oblivion/New Vegas, since i have my mod managers installed in the game folder, they have some issues with seeing and editing the INI files for their respective games, now linking the files and/or folders does fix that (i’m currently hard linking the INI files, but would prefer to just soft link the folders using the winecfg option)

Just ran into the same problem and i wonder if there is any progress with desktop integration shortcuts in lutris? Setting up links with wingcfg still doesn’t work. It keeps changing back to defaut value :frowning: