Back to the main site

Desactivte vk3d

Before the last update i could choose to activate or desactivate vk3d. For some games i preffer use directx 11 beacuse i have more fps. On environment variable i have put NOVK3D and value 1 but i have no idea if it s work or not.

1 Like

I would like to know this as well.

In unity games you can run -force-d3d11 -force-d3d12 -force-vulkan -force-gl-core

works with Hellpoint except -force-gl-core

That is all only for Unity games

Still can’t get Bright Memory to run in directx12

1 Like

It’s weird because by pcgamerwiki overwatch work only on directx 11


But i describe the issue before where vk3d was activate and i had less performance.
Maybe something to do to having nvapi disable. I dont know i always change manually. When i try with no vk3d the game process shader and it s work better.
image
I have found that u can put environment variable from wine so it NOVK3D for d12.
So with VK3D enable huge stutter and not more than 70 fps without i can touch 130 stable without stutter

You shouldn’t need to do this. Games should allow you to change from using dx12 or dx11. VKD3D only does dx12 to vulkan. Dx11 and below is DXVK.

There should be no game that forces dx12 when there are other dx versions supported by said game.

Though, I suppose if there’s a bug in the game and it won’t get to a point where you can select a version. In that case, you can technically edit the Lutris python file for the setting to not include VKD3D like the way they had it before. https://github.com/lutris/lutris/search?q=dxvk%2Fvkd3d&type=Commits

What I ended up doing was just downgrading the version of Lutris so that the toggles were visible again. Disable D3D and the games I was having problems with launched again. Not ideal, obviously, but there doesn’t seem to be any feedback indicating that the toggle will return in the future.

I know, overwatch haven’t even dx12 support. That s why it s weird. Gonna need more search to see what and where is the issue

If u change some settings sometime the prefix doesn’t register them. But go with novk3d on environment variable it s simple.