Back to the main site

Dependencies of World of Warcraft


#1

The Dependencies on World of Warcraft are incomplete. The ms-fonts need to be added. For Arch linux those are ttf-ms-fonts from the AUR (Arch User Repository), Link: https://aur.archlinux.org/packages/ttf-ms-fonts/ . For Ubuntu I read it is the ttf-mscorefonts-installer Package. Someone maybe wants to confirm on the ubuntu package.

I was missing those dependencies and always got an error with:
Battle.net Helper.exe crashing.

Also this dependency is probably needed for ALL Battlenet Games.


#2

on Debian it is ttf-mscorefonts-installer so I imagine it is that for Ubuntu also :slight_smile:


#3

note there should also be a winetricks installer for those fonts if i’m not mistaken, maybe that can be used in the lutris installer for WoW to get those dependencies in a platform-independent matter.


#4

Personally I keep getting this error with the news “ribbon” of battle.net, installed all dependencies on Solus.
Game running fine tho.

If someone knows how to get rid of that error I’d love to know it.