Back to the main site

D3/WoW fps dropdown

Hi everyone. So the problem is that I have 30-40 fps after I enter gameworld in WoW and sometime after fps drops down to 8-10 fps. I have installed Battle.net and than downloaded WoW through it, I don’t touch any of ingame setting. My laptop stats -
System: Host: manjaro-lp Kernel: 5.1.16-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.16.80 Distro: Manjaro Linux Machine: Type: Laptop System: ASUSTeK product: TUF Gaming FX705DY_FX705DY v: 1.0 serial: <root required> Mobo: ASUSTeK model: FX705DY v: 1.0 serial: <root required> UEFI: American Megatrends v: FX705DY.309 date: 04/25/2019 Battery: ID-1: BAT0 charge: 60.8 Wh condition: 60.8/64.0 Wh (95%) CPU: Topology: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP L2 cache: 2048 KiB Speed: 2518 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 2518 2: 1912 3: 1560 4: 1623 5: 2832 6: 2227 7: 2650 8: 2748 Graphics: Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] driver: amdgpu v: kernel Device-2: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting resolution: 1920x1080~60Hz OpenGL: renderer: AMD RAVEN (DRM 3.30.0 5.1.16-1-MANJARO LLVM 8.0.0) v: 4.5 Mesa 19.1.1 Audio: Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel Sound Server: ALSA v: k5.1.16-1-MANJARO Network: Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter driver: rtl8821ce IF: wlp2s0 state: up mac: dc:f5:05:01:73:d5 Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 IF: enp3s0 state: down mac: 04:92:26:1b:7b:46 Drives: Local Storage: total: 931.51 GiB used: 336.79 GiB (36.2%) ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB Partition: ID-1: / size: 915.40 GiB used: 336.79 GiB (36.8%) fs: ext4 dev: /dev/sda2 Sensors: System Temperatures: cpu: 36.4 C mobo: N/A Fan Speeds (RPM): N/A GPU: device: amdgpu temp: 36 C device: amdgpu temp: 38 C Info: Processes: 254 Uptime: 2h 48m Memory: 7.54 GiB used: 3.17 GiB (42.1%) Shell: fish inxi: 3.0.34
Any ideas how to fix that ?
With my previous laptop, I don`t have that problem (it was intel+nvidia).
Maybe I should try to install Catalyst driver or something like that?
Btw I run game with last Wine + DXVK + Feral gamemod enabled. And last time I have met the same problem in Diablo 3 with the same system/Lutris settings.

Change your DXVK_HUD to devinfo,fps,compiler and report back if wow is running with RAVEN (iGPU/Vega) or POLARIS11 (460X). If your computer is like my laptop it’s probably running Battle.net with the 460X and then switching to the iGPU to run WoW.

  • Evan

I don`t understand what i suppose to do about DXVK_HUD - You mean i need to change DXVK_HUD settings inside Lutris ? I have ASUS TUF gaming 705dy.

Yes, under the system options for the battle.net/wow game, if you enable advanced options you will see an entry for DXVK_HUD | compiler. Change it to DXVK_HUD | devinfo,fps,compiler

You have to hit enter/return before clicking apply on the window.

  • Evan

Like that ?

Yep, that’s perfect. You should get some white text in the top left window of WoW that will say something like AMD RADV RAVEN (LLVM 8.0.0) or AMD RADV POLARIS (LLVM 8.0.0).

My Wow subscription has expired. I can try it on Diablo 3. But there’s a video setting inside WoW where you can choose video card, but it seems to not work

Either game will be fine. We just want to see what’s on the login screen.

Ehm, ok… Is that what you needed?



Looks like it runs with Polaris 11(8.0.0)
Btw I’ve deleted WoW, so I was testing it on Diablo and after I start a game > the Battle.net window re-opens but none of the white text in left corner has changed.

Is it still using Polaris in D3 (the game itself)?

I don`t know. It was no info in game, only in battle.net window

There’s definitely something wrong (you should have the DXVK hud in the games) but it’s beyond my experience to help. We will have to wait for one of the devs to show up.

I’ve tried the same settings of DXVK_HUD in PoE and it works fine. So there might be a problem in Lutris itself.
Upd:
I’ve made it, but with next few starts don`t show up again


But there are still problem with fps dropdown after several minutes

Sorry for photo from my phone. Couldn’t take screenshot properly, D3 don’t allow me to alt+tab to any other program.

Do you have a windows install you could test d3 on the laptop with? It’s possible your gpu is thermal throttling. I’m on my phone right now so I can’t post the commands needed to check your gpu temp atm but I’ll follow up when I get home.

Does it happen in any other games?

If you’re using cinnamon (and possibly other gnome3 desktop environments) you may be able to windows key + d to get to the desktop while in Diablo.

No, i don’t have any of Windows besides on my laptop and it looks like there are no other games where I’m facing this problem but Blizzard games. I’m using Manjaro KDE if it necessary.