Back to the main site

Cursor lock in starcraft remastered

Hi guys, so I’m trying to play starcraft remastered. I have multiple monitors and the problem is that the game works fine when first launched. But as soon as I leave… lets say to change a song in spotify :man_shrugging: … and then I go back into the game the cursor its no longer locked to the screen, making the game unplayable. Is there any way to fix this?, so far I’ve not been able to find much documentation :frowning:

any input is really appreciated, thanks !

Hi,

Have you tried using the Mouse Warp Override option located: Right click on the game > Configure under Runner options tab. Make sure you tick Show advanced options and try the different options from there.

If this does not work you can try to go to wine configuration for Starcraft Remaster and under the Graphics tab tick Automatically capture the mouse in full-screen windows.

I would also recommend trying to play the game with Windowed (virtual dekstop) enabled which you can find under the Runner options tab.