Back to the main site

Crashing when running demo version of Ship Simulator Extremes

I have downloaded and installed the demo version of Ship Simulator Extremes which can downloaded from http://download.fileplanet.com/ftp1/092010/ShipSimulatorExtremesDemo.exe?st=X6fsR2cH0hqou7ZyWy6qHw&e=1595350271.

Website of Ship Simulator is www.shipsim.com.

Each time when I run this game under Lutris with Wine version ‘lutris-5.7-7-x86_64’, or an other Wine version which begins with ‘lutris-’, it crashes while displaying its splash screen. When I click at 'Toon Details/‘Show details’ I can’t even see a crash report at all, because it immediately vanishes. I have selected a 32-bit Wineprefix architecture, I have disabled Lutris Runtime and I have enabled preferring system-wide libraries. I don’t have added any DLL overrides like Vcrun2005 and d3dx9, to avoid interfering with the debugging process.

Part of the debug output when running this game:

Running /home/daw/.local/share/lutris/runners/wine/lutris-5.7-7-x86_64/bin/wine /home/daw/Games/ShipExtremesDemo/drive_c/Program Files/Vstep/ShipSimExtremesDemo/SSE.exe
Initial process has started with pid 6676
Game is considered started.
000b:fixme:winediag:start_process Wine TkG 5.7 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please don’t report bugs about it on winehq.org and use https://github.com/Frogging-Family/wine-tkg-git/issues instead.
001b:err:ntoskrnl:ZwLoadDriver failed to create driver L"\Registry\Machine\System\CurrentControlSet\Services\wineusb": c0000142
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"wineusb" failed to start: 1114
Initial process has exited.
002f:fixme:msvcrt:__clean_type_info_names_internal (0x15f2aa0) stub
002f:fixme:msvcrt:__clean_type_info_names_internal (0x2127530) stub
.
.
002f:fixme:msvcrt:__clean_type_info_names_internal (0x1e86610) stub
002f:fixme:msvcrt:__clean_type_info_names_internal (0x1f1c340) stub
002f:fixme:msvcrt:__clean_type_info_names_internal (0x15b7530) stub
wine: Unhandled page fault on write access to 7C002FD8 at address F53642EA (thread 002f), starting debugger…
Game is considered exited.
All monitored processes have exited.
Exit with returncode 0

System report:

[System]
OS: Linux Mint 19.3 Tricia
Arch: x86_64
Kernel: 5.4.0-40-generic
Desktop: XFCE
Display Server: x11

[CPU]
Vendor: AuthenticAMD
Model: AMD Phenom™ II X3 720 Processor
Physical cores: 3
Logical cores: 3

[Memory]
RAM: 3.8 GB
Swap: 5.0 GB

[Graphics]
Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce 9400 GT/PCIe/SSE2
OpenGL Version: 3.3.0 NVIDIA 340.108
OpenGL Core: 3.3.0 NVIDIA 340.108
OpenGL ES: OpenGL ES 2.0 NVIDIA 340.108 340.108
Vulkan: Not Supported