Copy games and settings to a new os install

i reinstalled my os, and did a backup of my home directory. i copied all files from “Games” “~/.local/share/lutris” and “.config/lutris” to the new OS installation. when i try to start overwatch the following happens
“Running /home/soul/.local/share/lutris/runners/wine/lutris-5.7-8-x86_64/bin/wine /home/soul/Games/overwatch/drive_c/Program Files (x86)/ --exec=launch Pro
Initial process has started with pid 21056
Game is considered started.
esync: up and running.
wine: could not open working directory L"unix\home\soul\Games\overwatch\drive_c\Program Files (x86)\\”, starting in the Windows directory.
Game is considered exited.
Initial process has exited.
All monitored processes have exited.
Exit with returncode 65280

the directory exists and when i click in lutris view install directory it opens it.

what can i do to get that to run ???

I guess your goal here is to minimise re-downloading it all. You said you copied it over, so I’m going to assume that you re-permissioned everything.

If you go into “Configure” in Lutris and try browsing to the .exe again manually, then try running it, it might kick it into life. Under “Wine configuration” in Lutris, check your drive mappings - do the paths make sense?

Failing that, you can re-run the client install into the same prefix (uncheck delete), as it has an option to find existing-installed games, and recover that way.

didnt work :frowning:

maybe i did the thing with the ownership wrong. i did chmod +R 777 ~/Games/

The sysadmin in me is saying “noooo” to 777, but in truth, it’ll work :slight_smile:

I practiced this on my Diablo III install - removed battle net, unckecked the option to delete files. Clicked install again, Lutris notes “it might not work as there are existing files”, but it installs without error.
Runs it, logged in, and the client automatically popped up with the “we’ve found your games” box on next run.

I’m assuming you used the Overwatch install script - comparing the two, its not that kind of different.

Check it hasn’t borked any of the configuration, like WINE version.
Click the “default” icon to reset it to the expected.

i know 777 is evil XD but i just wanted to be sure :slight_smile: still dont work, i think i just doin a reinstall of it. and final fantasy 14

Maybe do a fresh install into an empty prefix? If it works, copy the game files over manually and see if will take that as the install dir? Will tell you pretty quickly where the problem is and still be quicker than downloading it all.

i reinstalled them now, and copied the settings from the old directorys into the new ones