Configure/enable OpenGL shader in Mednafen runner

Hi all.

I’m on Linux Mint 20.3 currently. I installed mednafen runner but it couldn’t launch due to some errors. Then I installed standalone Mednafen and pointed Lutris to it’s executable. Now it works.

I can’t, unfortunately, find the way to enable PSX OpenGL shaders. There is no option to do that in Lutris itself. I’ve found a configuration file for Mednafen in /home/user/.mednafen/, edited it, but it took no effect at all.

Is there another way to enable OpenGL shaders for PSX emulation?

Thank you and best regards.

1 Like

Hey have a look at the documentation:

alternatively you could add the following to the Arguments box:
-video.driver opengl -psx.shader scale2x

this would be equivalent to launching it from the terminal as:
mednafen -video.driver opengl…

I’m on Lutris and there is no “Arguments” box anywhere to be found. I typed it into System options > Environment variables as a Key > Value pair, e.g. “video.driver” being the Key and “opengl” being the Value. Same for psx.shader scale2x. It either didn’t work this way or I failed to notice the difference.

Thank you for your effort anyways.

I actually gave it a go on the weekend I forgot to update this thread.
You need to disable the game settings for mednafen, you can see in the screenshot bellow that it is working with the default scaler I set up in the cfg file: