Conceptual help with EA Desktop on Steam Deck (for Mass Effect LE)

I gather that the situation with Origin on deck is tenuous with EA moving to their new EA Desktop/App and not going out of their way at all to be deck-friendly. But there is an EA Desktop install for lutris, and I managed to add that and run it on deck without much fuss.

I tried to do the same with the installer as a non-steam game, but afterwards I couldn’t get the resulting app to start at all through Steam. It would throw up black boxes and with Proton Experimental it just reported a vague error message and refused to start. So whatever lutron is doing is at least working in a way that Steam isn’t right now, at least to the extent I understand it.

But there’s no library integration with EA Desktop, so I’m on my own for trying to add games, and there’s a lot about the overall model here that I don’t understand or know where I can learn more about.

I gather than lutris has installed EA Desktop into a dedicated wine prefix which is just a root for all the fs-abstraction it does and that any games installed while running the wine-emulated EADesktop.exe will end up in that same structure. So when I want to run an installed game, I need to be referencing those same paths… I tried:

  • exe: /home/deck/Games/ea-desktop/dosdevices/c:/Program Files/EA Games/Mass Effect Legendary Edition/Game/Launcher/MassEffectLauncher.exe
  • working: /home/deck/Games/ea-desktop/dosdevices/c:/Program Files/EA Games/Mass Effect Legendary Edition/Game/Launcher/
  • prefix: /home/deck/Games/ea-desktop

But running fails with:

Started initial process 3753 from gamemoderun /home/deck/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-7.2-2-x86_64/bin/wine /home/deck/Games/ea-desktop/dosdevices/c:/Program Files/EA Games/Mass Effect Legendary Edition/Game/Launcher/MassEffectLauncher.exe
Start monitoring process.
Monitored process exited.
Initial process has exited (return code: 136)

I don’t know if I should expect to be able to launch from inside EA Desktop, but that also just fails.

There’s a lot about the overall architecture here I don’t understand. Maybe it’s too much to hope that a complex game with a store DRM dependency and its own launcher is going to work, but I also don’t know what my expectations should be or what layers to look at when there are problems. So many of the docs and wikis are stale or not concerned with the narrower deck ecosystem.

I’d be interested if there’s anything obvious I’m missing (particularly resources for understanding the fundamentals…I use Linux regularly but not for anything like this) but it’s also starting to feel like more trouble than it’s worth. I knew I’d regret buying from EA, and I won’t make that mistake again.

I got a little farther by copying the EA Desktop config and editing it to reference the game exe, but it just kept running the launcher, so I’m probably out for the time being. Maybe once the dust has settled with the EA Desktop transition someone will figure out a workable story for it, but right now it’s just not worth the time. I did find some helpful links along the way though.

Proton/proton at proton_7.0 · ValveSoftware/Proton · GitHub (i.e. wtf is the STEAM_COMPAT_DATA_PATH I keep seeing)
Also Proton issue 4823 which is over my quota for links in this post.