Company of Heroes 3 with huge Framedrops (<15fps)

First. This is no Lutris problem. I’m here, because Experts for Linux gaming are here.

I’m running Manjaro and want to play Company of Heroes 3. With my old hardware (i7 2700k, there was no problem.

Now i updated my CPU to an 12600k and the new Kernel which updated the sheduler for alder lake processors (>5.15) im running in bug framedrops(to 15fps). The problem is the game, not the kernel, not the hardware (i think so). If i running kernel 5.10 (with is LTS on my dist), there are also framedrops, but just till 31fps (whats means, it is playable at multiplayer)

Screenshot- 6.x Kernel:

the frame limiter is not the problem, same drops with vsync an 60fps cap.

you can the hat the simulation processor is the problem not the rendering part. do you have any sugestion for me?

i’m running the game at steam with proton an tried all versions. tried also the following start parameters:

I thried also to run the game with lutris, but it doesn’t start because of it is a steam game.

btw. diablo is running at highest settings at 100fps smooth like shit, so i thing there is no hardware are driver problem. running the newest nvidia drivers, that are packaged for my dist.

Screenshot with 5.10er Kernel:

same problem with EndeavourOS…