Command and Conquer Generals - Zero Hour faild to start since last update


I’m playing Zero Hour with my broter most evenings, but today it stopped working, the game freezes by startup. I tried:

  • changing wine version from 1.9.21 to 1.9.21 staging or 1.9.20 or 1.9.19

  • Disabeling lutris runtime

  • Start without Lutris with System Wine (1.8)

  • Start With PlayOnLinux (Wine 1.9.15)

    The Log information:
    xterm: /home/cronyk/.local/share/lutris/runtime/lib64/ no version information available (required by xterm)
    xterm: /home/cronyk/.local/share/lutris/runtime/lib64/ no version information available (required by xterm)

Neighter the terminal than Ubuntu gave me an error…

Can anyone help? Is there a change on

Oh, you’re lucky, I spent 2 hours on Monday working on the installer for Command and Conquer Generals and I also have Zero Hour sitting on my desk ^^

You have the German version, right? I’m making the installer for the English version but you should be able to adapt it easily. You can have a look at my C&C Generals installers, it wasn’t an easy task getting it to run :stuck_out_tongue:

I know, I installed it without the installer and I had to try it nine times… At the End I copied all disks together (the 10years version without origin) and installed it. And THEN I had to installl the uncut patch (you really don’t want to know the german version of the game :wink: )
So thank you, this are great news… But I have to reinstall the game? Because it worked once…

I had a fast look (I’m sitting in the lab right now…) and althought the game is called “Command & Conquer: Generäle - Die Stunde Null” in my version, the discs are also called “generals” and the exe is the same I think, so the only change would be to add “Generals-108-german.exe” (if this exist) to and than replace (for me) the line in the installer… I mean when the script starts the Installation from DVD I will still be able to choose install language, right? If not, there is a language patch somewhere at the internet, I’m sure :slight_smile:

If you need the patch, I’ve uploaded it here:

Be sure to copy the options.ini file to the correct location because that’s why the game wasn’t starting for me (crash on the splash screen). Zero hour probably has the same issue.

I tested the installation and it works flawlessly (what is very good), but the game just didn’t start at all… I will have a look at the 10 Years edition later…

Be sure to have the options.ini file copied in the right location

Apparently this is an issue on Windows as well.

Well, I Think so…
This is the Path i copied the ini from the link above:

~/Games/command-conquer-generals/drive_c/users/cronyk/My Documents/Command and Conquer Generals Data$