Code 256 2 hours and still not working Please help

2 link

Guys, I need help with this.
When I was working on my game, I decided to add some DLC, but the system kept telling me there was not enough space.
I have two MV.2 HDD’s 250GB each one has acro Linux and the other is empty with both being EXT4.

after a few tries I decided to do a Fresh installation of Linux and BTW get rid of all the other crap I have to make more space
so I formatted both HDDs to EXT4 as I mentioned above // Acrolinux on one and the other for games
Not to mention I don’t play games like crazy, and I hate errors, therefore I only install one game at a time on the free 250GB MV.2
1- make sure have enough space
2- no reason to load 2 or 6 games when I am only playing one of them

back to topic
I run lutris, and it starts fine, then I get you are not the owner of the external HDD
so I run sudo chmod 777 -c -R /dev/Path to your hard disk
still, Lutris says not enough space / no owner of the HDD

it has been 2 hours and 45 min no solution

please help

in my second and third links, I even tried to format the HDD in the terminal just in case G Parted was acting up
still nothing

1 Like

What you should to do is create a directory on the mounted hard disk, and grant your user ownership of that if you want to write there.

You’re trying to change permission on the device node. You don’t want to do that to the mount point either.

I use multiple drives as well (and also have a dedicted NVME drive for games… 2TB)

Every one of my storage drives has a directory on it that I own, and I do all my business within those. I know that my directory “shit” is on every drive.

For example I have my /dev/nvme0n1p1 mounted as /storage3 (in /etc/fstab). First of all, as root (or preface the commands with sudo)

mkdir /storage3/shit
chown -R grogan:grogan /storage3/shit

Where grogan is my user and grogan is my group (can also use UID and GID, for example 1000:1000). If just creating a new directory, you wouldn’t need -R (recursive) but I’m showing it in case the directory isn’t empty so your command won’t fail.

That should be it, own your directory and use that as the path for your game installs.

1 Like


Hay My Friend Thank you for responding. I'll try and get back to you.


Wait, there is a lost and found directory that I must delete?
Do I have to delete that directory?

No, just ignore lost+found, you’ll find one on every ext* filesystem. It’s for disconnected files in the event of filesystem repair (e2fsck) that can’t associate them with their directory entries again.

Just create your own directory, chown it, and use it.

1 Like


Okay, I’m almost here Ran the game, but I got three issues.

1- the game is dark
2- their delay, Lagging
3- Please refer to the photo.

So, I think I missed out on a pilot or something I have RX580 AMD.
Can you point me in the right direction in terms of finding the right drivers? Thank you
Moreover, if you know what is at the root of this please let me know.
Many thanks

I’ll wait for you / so I Can play my Train Sim World 2 .:slight_smile:

Your drivers are part kernel (amdgpu), part Xorg (display driver) and part Mesa (graphics driver libraries) which is usually the most significant in terms of upgrades.

You’ll generally upgrade them when your distro upgrades packages (otherwise you’d pretty much have to compile a newer mesa, e.g. mesa-git from AUR). Arcolinux, being Arch based, should have a pretty up to date mesa, latest stable 22.3.5. This is not likely your problem.

There is also a proprietary AMD driver but that likely will not help you with this stuff.

People are complaining about this game here (someone says the performance problems came with the last update). Some of the posts may help you.

Your missing cockpit could actually be HUD settings in game. You can probably turn it all off including that gauge. Lots of driving games are like that too, they let you turn off the dashboards etc.



Ok Many thanks

Im On The acrolinux site and i see a few options so lets see how that goes

Many thanks man :v: :slight_smile:

You’re welcome… happy to help if I can.

1 Like