Back to the main site

[Closed] UPlay can't download Rayman Legends


#1

Hello everybody,

I am very new to Lutris, so first of all many thanks for the good work :slight_smile: I have been trying (and failing) to setup Ubisoft Uplay by myself for a few days, but it work all by itself with Lutris!

Now, I am trying to download and install Rayman Legends from my Uplay account, but it doesn’t work. I get the message:

Download failure : please check internet connexion and disk space

Internet is OK and I have 28GB disk space remaining. I am using Linux Mint 18.

I tried to download it with “Lutris runtime” disabled to no avail (as suggested here : Starcraft Anthology battle.net issue).

Does anyone have an idea or a trick to download and install the game?

Many thanks in advance!
Arnaud


#2

I think this might be the same problem I experience with Assassin’s Creed II. The only way I got around it is by using an older version of Uplay. Try using the 23.0 version installer.


#3

Thanks a lot, I installed Uplay 23.0 and it worked like a charm, including Rayman Legends installation and launch.
I am facing a little bug (duplicated joysticks), but I will search the forum a little more.