Civ III complete edition gog closes automatically

I bought Civ III complete edition through GOG and sync’d my account to lutris. I then clicked “import game” and chose Civ. Then when installing I chose to install the GOG wine version.
After the installation I decided to “launch” the game. It then proceeded to open and then immeaditly close. I’ve tried to change the wine version to the 5.9 native and to proton 5 and it still behaved the same. when I opened the log menu these was the output

for lutris 5.6:

lutris-wrapper: Sid Meier’s Civilization® III Complete
Running /home/gabriel/.local/share/lutris/runners/wine/lutris-5.6-2-x86_64/bin/wine /mnt/jogos/lutris/sid-meiers-civilization-iii-complete/drive_c/game/Conquests/Civ3Conquests.exe
Initial process has started with pid 18839
Game is considered started.
Game is considered exited.
Initial process has exited.
All monitored processes have exited.
Exit with returncode 0

for lutris 5.7

l> utris-wrapper: Sid Meier’s Civilization® III Complete

Running /home/gabriel/.local/share/lutris/runners/wine/lutris-5.7-x86_64/bin/wine /mnt/jogos/lutris/sid-meiers-civilization-iii-complete/drive_c/game/Conquests/Civ3Conquests.exe
Initial process has started with pid 109781
Game is considered started.
wine: Unhandled page fault on write access to 0000001C at address F629C334 (thread 0038), starting debugger…
Unhandled exception: page fault on write access to 0x0000001c in 32-bit code (0xf629c334).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:f629c334 ESP:0032f9b0 EBP:0032fa68 EFLAGS:00010246( R- – I Z- -P- )
EAX:00000000 EBX:00000010 ECX:00000000 EDX:00000400
ESI:f6afd958 EDI:00000001
Stack dump:
0x0032f9b0: 7d018550 021ec600 0002018a 7e987b35
0x0032f9c0: 00000010 00000400 00000400 00000300
0x0032f9d0: 00000300 057d0000 00000300 00000400
0x0032f9e0: 0002018b 00000015 0032fa10 00000010
0x0032f9f0: 00000400 00000300 00000003 00000000
0x0032fa00: 00000000 00000400 00000300 00000800
=>0 0xf629c334 (0x0032fa68)
1 0x7a8b840e (0x0032fab8)
2 0x0062b2d0 EntryPoint+0xffffffff() in civ3conquests (0x0032fb1c)
3 0x004e2b84 EntryPoint+0xffffffff() in civ3conquests (0x009c3508)
4 0x00000000 (0x0066a63c)
5 0x004fcab0 EntryPoint+0xffffffff() in civ3conquests (0x004c94e0)
6 0x00000018 (0xe8f18b56)
0xf629c334: movl %edx,0x1c(%eax)
Module Address Debug info Name (74 modules)
PE 350000- 3cc000 Deferred jgl
PE 400000- cd4000 Export civ3conquests
PE 18f0000- 19ab000 Deferred sound
PE 10000000-1003b000 Deferred ifc23
PE 21100000-2115d000 Deferred mss32
PE 22100000-22114000 Deferred mssa3d.m3d
PE 22200000-22215000 Deferred mssa3d2.m3d
PE 22300000-22311000 Deferred mssds3ds.m3d
PE 22400000-22414000 Deferred mssds3dh.m3d
PE 22500000-22514000 Deferred msseax.m3d
PE 22600000-22616000 Deferred mssfast.m3d
PE 22700000-22716000 Deferred mssdolby.m3d
PE 22900000-22912000 Deferred mssdx7sl.m3d
PE 22a00000-22a12000 Deferred mssdx7sh.m3d
PE 22b00000-22b13000 Deferred mssdx7sn.m3d
PE 22c00000-22c18000 Deferred msseax2.m3d
PE 22d00000-22d62000 Deferred mssrsx.m3d
PE 24100000-2410d000 Deferred lowpass.flt
PE 24200000-2420d000 Deferred highpass.flt
PE 24300000-2430d000 Deferred bandpass.flt
PE 24400000-2440d000 Deferred reverb1.flt
PE 24500000-24510000 Deferred reverb2.flt
PE 24600000-24611000 Deferred reverb3.flt
PE 24700000-2470d000 Deferred reson.flt
PE 24800000-24810000 Deferred phaser.flt
PE 24900000-2490d000 Deferred parmeq.flt
PE 24a00000-24a0d000 Deferred mdelay.flt
PE 24b00000-24b0d000 Deferred sdelay.flt
PE 24c00000-24c0d000 Deferred ringmod.flt
PE 24d00000-24d0d000 Deferred flange.flt
PE 24e00000-24e0d000 Deferred chorus.flt
PE 24f00000-24f10000 Deferred shelfeq.flt
PE 25100000-2510d000 Deferred compress.flt
PE 25200000-2520d000 Deferred autopan.flt
PE 25300000-2530e000 Deferred laginter.flt
PE 25400000-2540b000 Deferred capture.flt
PE 26400000-2642c000 Deferred mssv29.asi
PE 26500000-26525000 Deferred mssv24.asi
PE 26600000-26627000 Deferred mssv12.asi
PE 26f00000-26f2a000 Deferred mp3dec.asi
PE 30000000-3006d000 Deferred binkw32
PE 7a840000-7a849000 Deferred opengl32
PE 7b020000-7b03c000 Deferred kernelbase
PE 7b420000-7b5f1000 Deferred kernel32
PE 7bc30000-7bc47000 Deferred ntdll
PE 7c9d0000-7c9d6000 Deferred uxtheme
PE 7d260000-7d265000 Deferred winex11
PE 7d360000-7d367000 Deferred iphlpapi
PE 7d390000-7d397000 Deferred ws2_32
PE 7d3d0000-7d3d7000 Deferred wsock32
PE 7d410000-7dd0c000 Deferred shell32
PE 7de40000-7de4e000 Deferred winspool
PE 7de90000-7de96000 Deferred imm32
PE 7dec0000-7dec4000 Deferred usp10
PE 7df20000-7df76000 Deferred comctl32
PE 7e050000-7e05a000 Deferred aclui
PE 7e070000-7e076000 Deferred shcore
PE 7e0a0000-7e0b2000 Deferred shlwapi
PE 7e100000-7e1ad000 Deferred comdlg32
PE 7e230000-7e25d000 Deferred ole32
PE 7e380000-7e400000 Deferred winmm
PE 7e450000-7e45d000 Deferred rpcrt4
PE 7e500000-7e528000 Deferred ucrtbase
PE 7e5f0000-7e5f5000 Deferred version
PE 7e610000-7e629000 Deferred setupapi
PE 7e6b0000-7e7a4000 Deferred user32
PE 7e8d0000-7e8dd000 Deferred advapi32
PE 7e960000-7e96e000 Deferred gdi32
PE f71b0000-f71bc000 Deferred dinput8
PE f7340000-f734a000 Deferred msacm32
PE f7850000-f7854000 Deferred winepulse
PE f78b0000-f78be000 Deferred oleaut32
PE f79c0000-f79c5000 Deferred mmdevapi
PE f79f0000-f79f5000 Deferred dsound
process tid prio (all id:s are in hex)
0000000e services.exe
00000022 0
0000001d 0
0000001a 0
00000013 0
00000010 0
0000000f 0
00000011 plugplay.exe
00000017 0
00000016 0
00000012 0
00000018 winedevice.exe
0000001f 0
0000001e 0
0000001c 0
0000001b 0
00000019 0
00000020 winedevice.exe
00000025 0
00000024 0
00000023 0
00000021 0
00000037 (D) C:\game\Conquests\Civ3Conquests.exe
00000049 0
00000045 15
00000044 0
00000043 15
00000042 0
00000041 15
00000040 0
0000003f 0
00000038 0 <==
00000039 explorer.exe
[C:\windows\system32\explorer.exe /desktop]
0000003e 0
0000003d 0
0000003c 0
0000003b 0
0000003a 0
System information:
Wine build: wine-5.7.r0.g2ad422ff ( TkG Staging Esync Fsync Vkd3d DXVK-Compatible )
Platform: i386
Version: Windows 10
Host system: Linux
Host version: 5.6.15-arch1-1
Game is considered exited.
Initial process has exited.
All monitored processes have exited.
Exit with returncode 1280

for wine 5.9 (my system version)

lutris-wrapper: Sid Meier’s Civilization® III Complete
Running /usr/bin/wine /mnt/jogos/lutris/sid-meiers-civilization-iii-complete/drive_c/game/Conquests/Civ3Conquests.exe
Initial process has started with pid 1977
Game is considered started.
wine: configuration in L"/mnt/jogos/lutris/sid-meiers-civilization-iii-complete" has been updated.
Game is considered exited.
Initial process has exited.
All monitored processes have exited.
Exit with returncode 0

so anyway I also tried to install gog galaxy on lutris so i could install civ through there, and it didn’t even launch

Edit: while writing this i decided to choose proton 4.2 as my runner and the game did launch only to crash when i decided to start a game so…
Please guide me, I’ve only had problems with lutris

arch linux
intel i5-7200U
intel graphics 620
8 gb ram

Hi there,
I’m not an expert in any meaningful way but I think it’s a problem with missing directx 9 dlls. Try to install a clean version (the gog version without modification) then select civ 3 in lutris and click on “winetricks”. Keep the option “Select the default wineprefix” selected and validate. Click on “install a windows dll or component”, validate and look for “d9vk” (latest). Install it and try to launch the game.
If you have any problem, don’t hesitate to reply. I’m a fan of civ and I would be happy to help you. I apologize for my broken english.

1 Like

I don’t know about the GoG version, but I remember on Steam I had to edit the conquests.ini file within the sid meier’s civilization iii complete\Conquests folder to get it working. Try adding the following line to that file:


wow, it took me some time but no, it didn’t make any difference. I opened winetricks and followed your instructions and when i was finished installing i clicked “play”
The result was the same
(wine 5.10)
Either way thank you alot for trying to help me. The game works with proton and the “keepres=1” string added to the conquests file even though there is no music when you play the game normally. That was why i tried to try again with wine. I like music.

Edit: After installing, I turned on the DXVK support and lutris stayed on “stop” so i changed to windowed mode and now I have the same music bug along with the dark terrain bug aswell. Oh well