Changing discs during install?

Hi folks,

I’m trying to install CoD1 (2003), and can’t get past the disc change prompt. Doesn’t matter if I use the original CD’s or disc images on CDEmu, I can’t eject to change discs, and can’t get the installer to recognise disc2 if it’s mounted on a separate drive. Force ejecting just causes the whole process to crash.

The Lutris installer (unpublished) for CoD has an eject button, but it seems to do nothing, or be blocked, as the drive is in use.

How do I install multi-disc/image games? None of the similar threads here seem to address the problem.

(Arch KDE)

1 Like

Have you tried copying the contents from the cds to folders on the HD, and pointing lutris to these folders instead of the cds.

Yup, tried that too, but there’s no way to point the installer to the contents of a 2nd disc, as it is waiting for “Windows” to inform the system that the disc has been changed, which doesn’t happen. Copying all the files to a single folder doesn’t work either. :-/

What about using innoextract

It’s a WISE installer. I managed to extract everything from Setup.exe, but there’s no usable install script that I could see, and convert. I’ve made ISO’s now, so i’ll install it on my laptop, which still has Win10 on it, and look for an installer tracer. Maybe I can reverse engineer a new script to install from a Dir with all files in it. Been a few years since i’ve done it, so any suggestions for installation monitors appreciated!

Why not use XP in virtualbox, if something goes wrong just delete the snapshot and start again. InCtrl5 was mentioned on exoDOS’s discord server for tracking win9x installers.

I think it’s more the challenge of getting it to install, and run in Lutris. I could just install it on the laptop and import the Reg entries in Wine, and copy the files over, but that would be too easy lol. It’s more the annoyance at not being able to figure out how to signal a disc change within Wine/Lutris that is bugging me, because there are lots of other games I will want to add.

I got Inctrl5 and will give it a go, thanks!