Change from radeon to amdgpu

Hi. I have ubuntu 18.10 on my lenovo g510 with radeon r7 m265 gpu. I have installed dxvk, wine hq staging, ppa drivers but nothing seems to work. Whenever I start Origin, it goes black and nothing appears. When I check the last game’s logs, there are several errors like FAILED TO CREATE D3D11 TEXTURE and I can see that Lutris uses integrated intel gpu rather than radeon. Looks like my card isnt used for this task.
Typing lspci -k shows that I have radeon and amgpu kernels but my system uses radeon kernel.
So I want to force to use amdgpu instead of radeon. Do you know how? These commands for Sea Islands and Carribean Islands dont work.

You have to blacklist the radeon kernel module so instead amdgpu will be selected at boot-time:

  1. Open /etc/modprobe.d/blacklist.conf with an editor, as super user
  2. Add this line: blacklist radeon and save the file
  3. Run sudo update-initramfs -u (in terminal) then reboot

To verify radeon is no longer active run `lsmod’ after the reboot in the terminal.

How to open that? Is it anywhere in “my files”? Or do I have to use a command in terminal in order to do that?

You most likely have to use the terminal to type these commands, I am not aware of anyway way to get superuser access using just the GUI. The way I would do this is open the terminal, then type the following command sudo nano /ect/modprobe.d/blacklist.conf. That command should open the required file you need to change. If the following command doesn’t open the file, then there is one more step that needs to be done before everything else. You will need Super User access, to get Superuser access you would type the following command as soon as you open the terminal. sudo su. I would strongly suggest trying first open the file you need using just sudo because you can damage your installation of Linux if you don’t know what you are doing. To get out of Superuser mode, just type exit at the prompt and that should take you out of Superuser access and back to a regular prompt.

Still the same. Now it doesnt show any kernel in use after I blacklisted this radeon.

I think you need to reboot your system after changing this file

@Przemekkk as Medath said, You need to reboot your system after changing this file.

I did reboot and nothing worked.
I have AMD r7 m265 which is marked as 1st gen of GCN and its codename is Oland. But it supports vulkan because I had it installed on windows

I am sorry @Przemekkk I won’t be of any more help, I haven’t been able to setup DGPU setup on my laptop. I just gave up trying to set up GPU pass through on my laptop because of the increased complexity of laptops. The only thing I can suggest other than abandon the project is to do more google research into your use case.

Blacklisting worked until kernel 4.12 but not later. Check which kernel you have. The commands now need to be added at boot time (grub)

  • Southern Islands (SI): radeon.si_support=0 amdgpu.si_support=1
  • Sea Islands (CIK): radeon.cik_support=0 amdgpu.cik_support=1

Which commands for Sea Islands and Carribean Islands did you try?

That being said, I could not make it work with SI card and kernel 4.18. It worked with the old method on kernel 4.11 though.

I have changed that and now it shows that I use amdgpu kernel. However, while installing Origin through Lutris, I get several errors, such as these below

I updated winetricks in terminal but it still shows that. And I have installed WineHQ staging. I dont know what to do.
Then I outputs error like GetConnectivity. So I guess it cant connect to internet.

This is another topic, you should open a new thread.