Can't run Star Trek game

Hi all. I’m trying to run Star Trek Online game on Lutris. I’m on NixOS 23.05. I’m not sure the game installed itself completely. But when trying to run it, I get an error message: “wine: RLIMIT_NICE is <= 20, unable to use setpriority safely”. It’s currently using the default Lutris-GE-Proton8-14-x86_64. I tried the other Lutris Proton runner with the same result.

Here is the complete content of the error log:

lutris-wrapper: Star Trek Online
Started initial process 42326 from /nix/store/yhi06ndanqg3z39f076zv4l2qfhkfv2q-libstrangle-unstable-202202022/bin/strangle 60 /home/martin/.local/share/lutris/runners/wine/lutris-GE-Proton8-14-x86_64/bin/wine /home/martin/Games/star-trek-online/drive_c/Star Trek Online.exe
Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
Le programme n’a pas pu tre lanc, ou aucun programme n’est associ au fichier spcifi.
ShellExecuteEx a chou: Fichier introuvable.

Monitored process exited.
Initial process has exited (return code: 256)
Exit with return code 256

Please read the pinned message and get the debug output - the “logs” border on useless in these cases as 256 is like a 404 error - something went wrong, but god only knows what…

I ran the lutris --submit-issue which gave a 33 pages document. One of the pages showed what I wrote. Do I have to copy/paste all 33 pages into the unbuntu pastebin?

Looks like it works with that much data.

I don’t know which version of Lutris is currently the newest one but I have this one.

Check the vulkan ICD loader on the System Options tab - make sure it isn’t set to unspecified

1 Like

It’s been set to this by default. I didn’t modify it.

Get the lutris -d output (make sure lutris is closed first) launch the game and then copy the terminal text (from lutris -d onwards) to pastebin and drop the link here

I already did.

Thank you for this. It fixed it for me.