Back to the main site

Cant run rocket league on Epic Games store

I have been trying to get rl to work on my machine ever since it went f2p. I have tried epic games store from lutris. It says running, minimises, then I can see rocket league logo on my taskbar, then it closes and EGS opens like nothing happened. I tried multiple wine versions. on windows 10 my specs give solid 60 fps on low settings.linux just refuses to work

This is the lutris debug log
https://paste.ubuntu.com/p/5cYGsFch8m/

This is the log from wine
https://paste.ubuntu.com/p/x6D2PbWtrj/

Any help is greatly appreciated.

Can’t see anything obvious there.

Start by disabling the overlay and see if it runs. Epic Games Store has its own debug log, enable that and see if it complains about anything.

If you are using the Lutris standalone Epic Games Store installer, it’s a fairly minimal setup.

I’d try installing VC++2015 etc. into the prefix manually if not already.

You can also try launching the Rocket League .exe directly rather than the epic store .exe; YMMV if there is integration between the Epic Store and Rocket League, or DRM.

Since it’s free on Epic atm, I’ll give it a go.

Works inside my Phoenix Point prefix, which launches the Epic Store. As I said, probably VC++ and/or .NET and/or DXVK.

Clone the Phoenix Point one, test, and submit an installer :slight_smile: