Back to the main site

Can't play the Fallout New Vegas intro wav file?

Hello,
I just installed Fallout New Vegas with the GOG version script Lutris on Zorin 15.2 64bits (ubuntu 18.04).

The script has some problems because the installation was incomplete (no Boss, no Nvse, no YUP)!
I was able to install everything manually and the game works very well except the sound of the intro which does not work?
Weird, on the same Lutris installation, I have Fallout 3 which has this same wav file and it works very well.
Definitely a Wine setting that is not correct in the settings, but I cannot fix the problem.
Please help me!

Does the log say anything?

lutris -d

and/or the log under the log button.

Thank for this quick response.
The log does not give much:

[INFO:2020-05-13 20:38:14,213:application]: Running Lutris 0.5.6
[INFO:2020-05-13 20:38:14,214:startup]: Using NVIDIA drivers 440.82 for x86_64
[INFO:2020-05-13 20:38:14,214:startup]: GPU: GeForce GTX 1070
[INFO:2020-05-13 20:38:14,215:startup]: GPU: 10DE:1B81 0000:0000 using nvidia drivers
[INFO:2020-05-13 20:38:14,317:startup]: Vulkan is supported
[INFO:2020-05-13 20:38:14,318:dxvk]: Updating DXVK versions
[INFO:2020-05-13 20:39:58,213:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/system32/dxgi with DXVK version
[INFO:2020-05-13 20:39:58,219:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/system32/d3d11 with DXVK version
[INFO:2020-05-13 20:39:58,227:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/system32/d3d10core with DXVK version
[INFO:2020-05-13 20:39:58,232:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/system32/d3d9 with DXVK version
[INFO:2020-05-13 20:39:58,242:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/syswow64/dxgi with DXVK version
[INFO:2020-05-13 20:39:58,248:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/syswow64/d3d11 with DXVK version
[INFO:2020-05-13 20:39:58,257:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/syswow64/d3d10core with DXVK version
[INFO:2020-05-13 20:39:58,261:dxvk]: Replacing /home/max/Games/fallout-new-vegas/drive_c/windows/syswow64/d3d9 with DXVK version
[WARNING:2020-05-13 20:45:28,648:game]: Game still running (state: running)
[INFO:2020-05-13 20:45:28,649:game]: Stopping Fallout: New Vegas (wine)

The curious thing is that I have the music with the launcher panel, it’s the same, I think. It works on the launcher but not by starting falloutnv.exe for the intro of the game?

The log doesn’t say too much. :frowning:

I was kinda hoping for file not found errors. I remember modding Fallout / ES games and missing textures because the case of the filename didn’t match the one the game requested. Not a problem on Windows but absolutely a problem on Linux as it is case sensitive.

Are you testing the vanilla version of the game or the modded one? Does it happen with the vanilla version too or is it triggered by the installation of a mod?

No mod on this log!

And stronger, I took the complete folder and loaded on Windows 10, the sound goes impeccable!

I played for an little hour on Lutris, everything is very fluid

This is really a problem with Wine, and why just a problem on the intro?

Incomprehensible, and why Fallout 3 Goty, goes very well intro, the settings of Lutris are identical.

I found this link:

https://linuxguideandhints.com/fedora/winetips.html

It mentions installing the l3codecx winetrick for mp3 support.

Thanks for looking, the article is interesting.
I tried to install I3codec with winetrics, then added “I3codeca” with “builtin” in Overrides at random … No change.
I have also tried a lot of modifications, but no success so far.

After checking with Windows, I realized that I also had no background music!

Since then, I installed the game with a GOG script, all the musics works!
On the other hand, the image is less good …, I have strange spots / “flashes” which appear when I move outside

I had this with SkyrimSE running through Proton recently. I had to add this pre-launch argument in Steam:

WINEDLLOVERRIDES="xaudio2_7=n,b" %command%

Maybe the script does something with xaudio which enables sound? I would look at differences between the scripts.

The link to the issue on github:

Thank you for your efforts tfk…, but I have already tried with this parameter also found on the Net … nothing!

So just to be sure I understand correctly, you opened WINE configuration and added a dll override with native, build in for xaudio2_7.dll?

These examples came from users running Proton BTW.

Yes, absolutely sure:
In the library window at the bottom:
xaudio2_7, native, integrated

I just did a new install of the GOG script from New Vegas using this time Mint 19.3 64 bits.
Same result, no intro sounds, no background music?

I’ve dived a little deeper using SkyrimSE. I wanted to enable modding on the Proton version of the game.

I found this:

The maintainers of this repo keep this one up to date as they find the Lutris system a bit too centralized amd therefore don’t update the scripts on Lutris any longer. That’s a matter of opinion of course.

Anyhow, it works quite nicely.

It basically installs ModOrganizer and lets you choose the game you want to manage. ModOrganizer is started by a shell script and the installer creates symlinks to let MO find the game.

This solution with Mod Organizer is certainly interesting, (to see as soon as I have a little time), but do you still have to have a game that works correctly.
For now I game with Fallout 3 because the GOG script is really good. I hardly saw any difference in performance with Windows.
With New Vegas, it is not the same, we are very far behind Windows!
On Fallout 3 with the Lutris installation from GOG I use for modding:
-Jsgme to load mods manually.
-FOMM for the “fomods”
-Mator Smash 1.0.2 to sort data (40 mods + FO3 Wanderers)
-And Loot to adjust the loading (Boss is obsolete)
With these utilities, not differenceve the game Linux as well as with Windows

SkyrimSE works flawlessly. I have a good set of mods installed, LOOT works fine, FOMOD installer are handled via MO. I can try New Vegas (steam version) later.