Can't play Overwatch at all

Since a random Major Update Pop_OS! had like 2 months ago, I have been completely unable to play Overwatch 1. It’d say “No compatible graphics hardware found” or something alike, crash at the “Connecting…” screen. No solution was ever found, no idea what could’ve broken it, it was completely flawless the day before.

I decided to wait for Overwatch 2’s release and hope that wouldn’t happen, but new errors arose. First, it asks me to use Windows 10 or above, no idea how. Then, it launches a black screen that crashes in a few seconds. I am unable to play this game and I don’t understand why, I already reinstalled it on Lutris, played a lot with its settings and so on. Everything is up to date, and other games work with no problem, like Diablo III or Sims 4. No idea why is this happening, I need help, but I think it might be too specific to find a solution, ever, I’ve been trying a lot of troubleshooting :frowning:

Screenshot from 2022-10-04 13-07-01

1 Like

Tried reinstalling, now, I can’t go past this message, it won’t allow me to install it. I can already see there won’t be a solution, just like last time. Linux is really terrible for gaming, the worst experience I ever had, it’s really, really saddening, I hated the bloatware of Windows.

On Lutris, navigate to the wine glass and click the up arrow beside it to show the menu, selecting Wine configuration. The resulting window allows you to change to Windows 10 - press apply then Ok to save the changes.

Screenshot from 2022-10-05 10-15-26

Screenshot from 2022-10-05 10-17-39

1 Like

I launch OW2 by steam, but it freezes randomly, which never happened in OW1. I’m using GE-Proton7-36, and set launch option DXVK_ASYNC=1 DXVK_FILTER_DEVICE_NAME="NVIDIA" gamemoderun %command%:

  • DXVK_ASYNC=1 to enable dxvk-async
  • DXVK_FILTER_DEVICE_NAME="NVIDIA" to force the game using nvidia gpu

In launcher set the games to never update from settings or set the to completely exit after launching a game. Have the same issue with WoW freezing cause dies in the background.

1 Like

First time playing Overwatch 2, and it randomly crashes for me. Could it be anti-cheat kicking in?

I just installed it and I am seeing the same. I might switch over to running through the Caffe-7.18 runner and see if that makes a difference.

Same here, I’ve tried with multiple runners (wine, proton-ge, soda etc) all the same, happens on a tick 1m/3m etc, so looks indeed like a anti-cheat system :frowning:

Overwatch 2 freezes for me at the queue screen. One time I made it to the main menu but it frooze.
Is this the same that is happening to you guys?

Switched to the Caffe-7.18 runner and was able to do a AI skirmish training run and Route 66 run. Realised half way through I didn’t have a corectrl profile for overwatch so was playing it using my powersave profile (500mhz on the GPU, huge undervolt etc). Now it says 8000 in front of me on the queue for a game server

I can confirm that Caffe runner is working fine. I’ve used it with Bottles with Futex2 and at least it worked about 10 min in a training ground + 1 full match.

1 Like

I walked away and came back to 60K in front of me!!!

Also working here with Caffe.
If I quit and start the game, it will say compiling shaders and stutter for a while. But, why again?

Thank you so much for this fix. It launches now, so far, though, haven’t been able to play due to the DDoS attacks, I want to believe. It said “2000 people ahead of you” and never changed for 15mins, then it froze and crashed (no button would react, had to Ctrl+Tab to Lutris and kill it with “Stop”).

I will wait until the game is more stable and test, see if it’s another problem with my Lutris or Wine, hopefully not, but so far so good, thank you!

I installed the caffe runner via the ui and assigned it to battlenet. But battlenet does not start. Anyone else having this problem?

All this was solved by following the Lutris Discord’s guide for Caffe Launcher instead of the usual Wine/fshack, and an specific DxVK version installation. Thanks everyone.

The overwatch caffe does not work on Ubuntu 20.04 due to a library version. The flatpak version was recommened but is unplayably slow compared to the apt version.

I think you need to update the Mesa or Nvidia drivers in the flatpak if the performance is slow.