Can't play or re-install League of Legends


I’ve been playing LOL on Lutris for a few months and I really appreciated it, it was really less buggy as compared to PlayonLinux.

But today I just couldn’t launch the game. Whenever I pressed the “play” button it just didn’t respond.
I tried to remove the game then re-install it, and now I just don’t manage to do it.

I did two things.

  1. Right click on the “league of legends” line in Lutris, and “install” >> nothing happened.

  2. Right click, add manually :
    Runner : wine
    Wine version : 1.9.2-stagging-lol-i86 (the one I used to work with)
    Executable : I selected the lol .exe installer file that I had just downloaded
    Click the “add” button.
    Then I clicked the “play” button >> nothing happened
    Then I right clicked on “league of legends”, “Run EXE inside wine prefix”, selected the same lol.exe installer file >> nothing happened …

Does someone know what I did wrong and could help me ?

Note : LOL doesn’t work on PlayOnLinux (I don’t know if it’s new or not, I wasn’t using it anymore). Error message says LoLPatcher.exe encountered a serious problem and had to close.

Thanks a lot for your help !


I’ve tried launching LoL and it did crash indeed.
I tried launching with Wine Staging 1.9.21 and it did not crash, the game is currently updating and I’ll see if the game works properly.

The latest LoL update works great with Wine Staging 1.9.21. I haven’t tried an online match, only a bot match, can you try and tell me if everything works alright? (if not, I might release a patched version of Wine 1.9.21)

thank you for your fast answer !

Could you let me know if you used Wine Stagging 1.9.21 i386 or x86_64 ?

Moreover, as I mentionned, I uninstalled the game and now am not able to install it. I still have the same issue by using those new versions of wine, nothing seems to happen, either by doing 1. or 2. (see my previous post).

Thanks !

I’m running the game with the i386 version but you can use x86_64 with a 32bit prefix if you want.

I haven’t tried the installation as I already had the game installed. I’ll test that and report back.

The official Windows installer is really tough to get working in Wine so I did exactly the same thing that was done before: installing the game outside of Lutris then just copying the launcher into an archive.

The current installer now downloads the current launcher updated today and it should start the game just fine (at least it does for me)

Thanks for your answer.

But I am sorry I am really beginning with Lutris / Linux I don’t understand very well what I should be doing :x

I can’t install the game using the install button from the website.

I also downloaded did this :
download the “” archive, extracted it
In Lutris, right cick on LOL, “add manually”, chose the correct runner and the file “lol.launcher.exe” as the executable.
Then I pressed “play”. >>Nothing happened

Again, I am not facing a crash or something. It just does nothing. I am not even sure I am doing the right thing actually …
Could there be something obvious that I am missing ?

Does clicking the install button launch your currently installed version or do nothing at all?

If it’s the first one, you can either remove the non working installation and re-click the install button or you can keep the installed copy and reinstalling another version by right clicking on LoL in the Lutris client and choosing “Install another version”.

If the “Install” button does nothing then the URL handler isn’t installed properly and you should tell me what distribution and desktop environment you’re running so I can have a look.

Also, make sure to click “Add to library” on the game’s page and connect to your account in the client, that way you can always install the game even without using the website.

That won’t work by itself, the installer does other things to setup LoL and you would have to go thought each one of them manually to add the game that way.