Back to the main site

Can't login to Ubisoft connect

its a fresh install and can’t login to be in offline mode.

It says “there seems to be a problem with your internet connection. Please check your settings or switch to offline mode.”

can anyone help me please?

1 Like

you need an additional package.
On arch it’s: lib32-gnutls
Ubuntu: libgnutls30:i386
Fedora: gnutls.i686

If you want to make sure you got all packages that might impact this in the future or i did not list your OS you can go to the Blizzard launcher site from the lutris github and install all the listed dependencies there.

4 Likes

it works! Thank you very much mucan! I’ll save this one.

Thanks a lot man, i had the same issue with Ubisoft Connect today and installing Gnutls 32bit worked.

Why are they not using the 64bit version of these files?

This does not work for me with ubisoft connect. I have the required files installed but still get connection lost.

Yes, I’m having the same problem. I tried making sure all the dependencies are installed. I don’t even know how to get to any logs to see what the problem is.

There is a launcher_log.txt file in the launcher folder (I use epic store but you may use the ubisoft launcher) I pasted today’s attempts. Ubisoft Connect Loses Connection - Pastebin.com

Mine looks a bit different than yours. [ 284] 2022-05-09 12:53:39 [ 288] INFO HubUtils.cpp (165) - Pastebin.com

I’ve also tried downloading the game through Steam using Proton and it installs Ubisoft Connect there as well and I get a similar issue and log entry. [ 348] 2022-05-09 14:44:00 [ 352] INFO HubUtils.cpp (165) - Pastebin.com

have you tried running AC: Valhalla through

Lutris > Ubisoft Connect

and not

Lutris > Epic Games > Ubisoft Connect?

Yes, both ways. neither works

Just as an fyi I think I found the issue but not something I can fix. I installed openssl1.1.1 and libssl1.1.1 and still have this issue. here is the pastebin Ubuntu Pastebin notice line 63 which states [0512/142209.424:ERROR:network_change_notifier_win.cc(228)] WSALookupServiceBegin failed with: 0

hello @bjb1959 and everyone else that might help,

I have installed Ubisoft Connect myself and I am able to explore the store without any issues.
I have found out that you can list the accessed libraries, here you can find the libraries accessed in my case:
Bottle Libraries
Winserver Libraries

Please follow the following instructions:

  1. Start the Ubisoft Connect program from lutris.
  2. Run the following command:

    pgrep -xa “python3”

  3. This will give you the program id (PID) list, in my case:

    31411 python3 /home/user/.folders_git/lutris-pf/bin/lutris
    32583 python3 /home/user/.folders_git/lutris-pf/share/lutris/bin/lutris-wrapper Ubisoft Connect 0 0 gamemoderun /home/oscar/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/bin/wine /mnt/Linux_McQueen/Lutris/ubisoft-connect/drive_c/Program Files (x86)/Ubisoft/Ubisoft Game Launcher/UbisoftConnect.exe

  4. Select the PID that has the “Ubisoft Connect”, in my case 32583, and run the following command:

    sudo pldd <PID>

  5. Copy the output into a ubuntu pastebin, this will help us compare.

Repeat the steps for the wineserver, but instead of step 2 run:

pgrep -xa “wineserver”

I hope this will give us the difference in our installations and possibly a solution to your problems.

Once I got the correct libraries installed the issue was actually ubisoft servers not being available. imagine that. I am able to launch and run the ubisoft store without issue. Now all I have to do is figure out why Assassins Creed Valhalla has this black flicker issue. - YouTube

1 Like