Can't Login to Origin: "Online login is currently unavailable"

I removed Origin from Lutris and started installing the legacy version. Then I logged into my account using legacy version. Then I removed the legacy version and re-installed the latest version of Origin and the login issue seems to have been fixed. It is currently working.
Lets see how long it will stay this way.

Here’s what seems to fix it for me, for all Origin installations i tried (Sims, fifa, bfbc2, bf1) on arch linux:

(Looks like a long list, but once you copied proton, its actually pretty easy and does only take a minute or two for each install)

  1. Delete the games files from lutris if already downloaded.
  2. Install from lutris like you normally would.
  3. Start. If it works, your lucky, if not and it says online login not available, continue
  4. Exit Origin
  5. Go to .local/sgare/lutris/runners/wine and create a folder “proton_4.11”
  6. Make shure Steam has Proton 4.11 Downloaded. If not, Enable Steam play for all titles, set Version to 4.11, try to run a game, Steam will download it.
  7. Go to steamapps/common/Proton 4.11/dist and copy all the files to the folder you created. => I just noticed that lutris now seems to detect Installed Proton Versions automatically, so coping might no longer be necessary :slight_smile:
  8. Restart lutris and change the runner of your game to proton 4.11. But dont run it yet!
  9. Open your games files and go to drive_c/programs x86/origin and delete everything but origin.exe and
  10. Run in terminal, and immediately after you start the script, delete origin.exe
  11. When script is finished, run Origin and login.
  12. After successfull login, Exit Origin again.
  13. Change the runner back to the previous one from the install script.
  14. Run and login again, you should be good to go :wink:

Note: When using proton 4.11, Origin seems to not be able to install games, but u can still try, but steps 13 and 14 were definetly mandatory for me. Steps 5-7 and the restart after that only have to be done once.

I hope this helps somebody, please report back :wink:

Have a nice day (hopefully playing games :wink: )

Thanks!!! <3 worked for me on the second try. Looks like step 1 is really important :sweat_smile:

Updated workaround, if this one doesnt work:

Instead of changing version to Proton 4.11, just leave it at the default, delete the files and run the updatescript, then disable esync, start the game => origin should update normally, then reenable esync :slight_smile:

Running steam is also broken (at least on Ubuntu) so maybe there is some other option?

Do you mean running steam through lutris or running steam-native or steam-runtime?

Every game that uses Windows Steam in Wine as a runner fails on installation for my Ubuntu machines. It keeps using my Linux local steam application for some reason. I got it working somehow today but while steam works it’s not visible in lutris so I probably remove it anyway. I struggle to get a grip on the runners.

Maybe just use native steam and proton? :thinking:

I’m not familiar with Proton, is it for Windows emulation within the Linux Steam client? I will check it out, thanks. I thought Wine was always the way to go…

Here’s a quick roundup:

  1. Go To Steam Settings, enable Steam-Play (and maybe also steamplay for all titles)
  2. Go To ProtonDB to find out what games work and with which version, if a game doesnt work or needs workarounds
  3. If another version is needed, just go to the games settings and change it

It was enabled but I had to re-enable it for Proton to start downloading. So that a great step forward, thanks! First game I try is Age of Empires III and it does not work without some tweaks (I read the forum posts on protondb), I thought Lutris was ment to manage those tweaks but I messed around with Protontricks myself and now the game runs great. Is there no ‘protontricks dependency’ thing in Lutris? I can now run the game directly from Steam right, why use Lutris.

Tried the workaround above but to no avail, there is no way to get Origins working.

origin works great with proton 4.11.

Well, basically proton is the way to go for most steam games. For all other games, just use lutris. What do you mean with no available?

“to no avail” meaning; without success :slight_smile:

Maybe you need to do both, switch to proton AND disable esync for the update to complete? Also, pay attention, sometimes the ownership of the origin Folder under programs (x86) seems to change, so you might just need to do a chown. Also, form what I read, it could help to let the origin update fail and then copy the downloaded update from programdata/origin/selfupdate/staged into your origin folder and then launch it

Hey guys,
one year later I might be coming late to the party, but I still have the same issue. Already ran the script standalone and also tried to delete everything besides the script and the origin.exe but still have the issue that the login is unavailable. Have Proton 5.13 installed and tried to running the program with this runner, but it wasn’t a solution either. I’m on Manjaro by the way and trying to run Battlefield V.
Since the original issue is already more than one year ago, I was wondering if there is a different fix for it or am I missing anything?

This might be meaningless, but it’s worth a shot
Try opening the ports needed for Origin:

  • TCP : 80, 443, 9960-9969, 1024-1124, 3216, 18000, 18120, 18060, 27900, 28910, 29900
  • UDP : 1024-1124, 18000, 29900

Thank you.
In between, I’ve found a solution, however sort of by accident. I installed the package ib32-gnutls in order to be able to be able to log in into Uplay and this somehow fixed the issue for origin. Maybe this will help others who have encountered the same problem.


I have the same problem on Manjaro but on Mint 20 working no problem

Installing lib32-gnutls worked for me too, at least to get Origin to let me log in for the first time!

1 Like