Back to the main site

Can't Login to Origin: "Online login is currently unavailable"

I had the same issue ~2 weeks ago. You can try to run ttheupdateorigin.sh script, if it’s present your origin folder (…/drive_c/Program Files (x86)/Origin).
Otherwise you could try to use the https://github.com/DrDoctor13/wine-origin-updater script.
You should also check the origin paths in the script file.
For me, after running the script, the login works.

I have this problem too. update script dont help(

I’ve done this on both Linux Mint 19, an old Macbook and Ubuntu 19.04 fyi.

  1. Download Sims 3 or another legacy game from Lutris Website it should say Open XDG-Open on your Firefox or Chromium (not Chrome) Browser. It will open in Lutris.
  2. You don’t need Sims 3 or the legacy installer game you choose, the reason why you should do it this way if you have little to no coding knowledge so you don’t mess up your wine configurations. Do not actually install Sims 3 once you are logged in, install your game after lutris goes through it’s normal configuration step.
  3. Next, disable game updates and as you are installing your chosen game, disable Origin-In Game and select in your settings “ignore non-mandatory updates.” Now the "origin online not available message has disappeared.

IMPORTANT: Just know when you access your files to add your game mods or scripts it will be under the folder /home/user/Games/the-sims-3/drive_c/users/user/My Documents/Electronic Arts/"Game Name"Sims 3 folder will act as an aggregator on the virtual drive even if you don’t have sims 3 installed.

I was able to add my mods to Sims 4 as well as access Battlefield and other games. Hope that helps. Also don’t forget to donate to Lutris, Linux and the open source community!

I have the same problem.

I have exactly the same problem, I tried everything, even on another computer…

1 Like

Hi Guys,

I´ve been looking for a solution as well. It wasnt easy to find but what helped was from the following Reddit post
They advice to Download here and install it with Lutris using “Run Exe inside Prefix”.
But please keep in mind, that the offered Link is not realy trustworthy. Its not from EA´s official Homepage.

Has anyone found an official fix for this?

So uh, this is dumb, but I got it to work by choosing Proton 4.11 as my Wine version in the Runner options tab.

More details, Origin will complain it’s out of date. Go to the Origin directory …/lutris/origin/drive_c/Program Files (x86)/Origin/, nuke everything there except updateorigin.sh and Origin.exe. Run the script from terminal, once it starts, nuke Origin.exe and let the install finish. It seems the update fails when there’s files in there, I have no idea why.

Thank you mate, this did the trick :slight_smile:

Where did you get Proton 4.11 though? I don’t have it as an option in the wine versions. Highest one I have is Proton 3.7?

I believe it came with Steam, however the newest version as of this post is 4.13. Latest versions of Proton can be found here: https://github.com/ValveSoftware/Proton/releases . You can also use tkg-protonified which is think comes pre-packaged with Lutris.

I had the same problem i downloaded that origin version https://origin-a.akamaihd.net/Origin-Client-Download/origin/live/OriginUpdate_9_12_0_34172.zip then replaced all files in origin folder. Run origin in lutris and wait for update. I tried it 2 times and each time worked.

Wine version: ge-protonified 4.9, ubuntu 19.04, D9VK

I tried doing this w/ ge-protonified-nofshack-4.9-x86_64 (default) wine version since i couldn’t find Proton 4.11 and it didn’t work.

  1. Install Origin from Lutris with wine proton 3.21 after install close lutris
  2. Download that origin version https://origin-a.akamaihd.net/Origin-Client-Download/origin/live/OriginUpdate_9_12_0_34172.zip
  3. Replace all files in origin folder
  4. open terminal in origin folder ( folder with origin.exe file)
  5. run ’ chomde +x updateorigin.sh ’
  6. run ’ sudo ./updateorigin.sh ’
  7. after update open lutris and run origin, should be in online mode
1 Like

I got it working by downloading https://origin-a.akamaihd.net/Origin-Client-Download/origin/live/OriginUpdate_9_12_0_34172.zip & replacing files, running the updater a couple times, and changing the wine version to Proton 4.2. In retrospect, not sure if the updating bit was necessary, but I tried a few different wine versions in between and Proton 4.2 was the only one I had that worked.

Actually, never mind; although I managed to log in and download games, it crashed for some reason and now won’t open at all, just hangs indefinitely.

EDIT: I tried switching around to other versions of Wine and then back to Proton 4.2 and it’s working like a charm now. ‾\_(ツ)_/‾

Actually, I just removed my install’s for FIFA and sims and redownloaded them from Lutris and for sims now it just works :slight_smile: so it seems to be fixed ^^ Origin even asks for 2FA whereas before it never did. With FIFA, It’s still not working. I’ve managed to get origin running using the workarounds, but with every workaround, the game install fails.

I removed Origin from Lutris and started installing the legacy version. Then I logged into my account using legacy version. Then I removed the legacy version and re-installed the latest version of Origin and the login issue seems to have been fixed. It is currently working.
Lets see how long it will stay this way.

Here’s what seems to fix it for me, for all Origin installations i tried (Sims, fifa, bfbc2, bf1) on arch linux:

(Looks like a long list, but once you copied proton, its actually pretty easy and does only take a minute or two for each install)

  1. Delete the games files from lutris if already downloaded.
  2. Install from lutris like you normally would.
  3. Start. If it works, your lucky, if not and it says online login not available, continue
  4. Exit Origin
  5. Go to .local/sgare/lutris/runners/wine and create a folder “proton_4.11”
  6. Make shure Steam has Proton 4.11 Downloaded. If not, Enable Steam play for all titles, set Version to 4.11, try to run a game, Steam will download it.
  7. Go to steamapps/common/Proton 4.11/dist and copy all the files to the folder you created. => I just noticed that lutris now seems to detect Installed Proton Versions automatically, so coping might no longer be necessary :slight_smile:
  8. Restart lutris and change the runner of your game to proton 4.11. But dont run it yet!
  9. Open your games files and go to drive_c/programs x86/origin and delete everything but origin.exe and updateorigin.sh
  10. Run updateorigin.sh in terminal, and immediately after you start the script, delete origin.exe
  11. When script is finished, run Origin and login.
  12. After successfull login, Exit Origin again.
  13. Change the runner back to the previous one from the install script.
  14. Run and login again, you should be good to go :wink:

Note: When using proton 4.11, Origin seems to not be able to install games, but u can still try, but steps 13 and 14 were definetly mandatory for me. Steps 5-7 and the restart after that only have to be done once.

I hope this helps somebody, please report back :wink:

Have a nice day (hopefully playing games :wink: )

Thanks!!! <3 worked for me on the second try. Looks like step 1 is really important :sweat_smile: