Back to the main site

Cant log in to WoW Classic

Hi,
My game has been working flawlessly up until last night. I log in, but when I choose the realm I want to play on, I get stuck at “Logging in to realm”, which eventually times out and give me a Wow51900328 error.

Ive tried reinstalling the client, deleting addons, deleting cache and WTF folders and tried logging on on a different PC on the same network (which works fine, it was a PC running Windows, which makes me inclined to think this is either a lutris or firewall issue)

Other Battle.net games like overwatch work, but both retail and classic WoW will not log in.

I’ve got no idea what else to do!

Same problem here - can’t log in, can get realm list, but stuck logging in to server and eventually wow51900328 error. This was working fine 24 hours ago.

Glad to hear it’s not just me! Its quite frustrating! I don’t understand how I can log into my account, retrieve a realm list but then get stuck logging into the realm!

UPDATE: I disabled my firewall and tired again, still stuck at logging into realm, clearly it isn’t the firewall preventing packages being sent and received!

UPDATE: Ive done some digging, the prevailing theory is that Blizzard is blocking all linux machines as a counter measure against the recent DDOS attacks!!

I read about the ddos on the blizzard forum.
But had no idea this was going on targeting linux users. kinda of a dick move. i might add.
If i find any work around will post a follow up.

I hope this gets resolved soon. I was having a blast with Classic, and now I’m locked from playing it because Blizzard decides I’m not good enough? -.-

1 Like

Changing default ttl from 64 to 128 made it work for me, here:
/proc/sys/net/ipv4/ip_default_ttl

it’s what blizzard uses to determine you’re on linux

1 Like

Changing default ttl from 64 to 128 made it work for me, here:
/proc/sys/net/ipv4/ip_default_ttl

Could you expand a bit more? My networking knowledge is quite poor!

EDIT: I manually changed the file, and it worked!!!

1 Like

sudo sysctl -w net.ipv4.ip_default_ttl=80

1 Like

Dang, thanks so much for this. This worked. Could you explain why changing the TTL to 80 works? Edit: nvmd, it was explained a few posts up. It’s how blizzard determines we are on linux. From their end, the seems like a very hacky way of solving the problem. I hope they have a more sophisticated solution in the works.

blizzard under dos attacks. How much this will help is not known, but so far it works. Blizzard did not find a solution,they are silent. Linux community find this solution with TTL. Some Windows users have encountered such a problem

“sudo sysctl -w net.ipv4.ip_default_ttl=80” Remeber this solution do after each reboot. If you want to leave the fix forever, edit /etc/sysctl.conf.

Background explanation: https://subinsb.com/default-device-ttl-values/

And thanks a lot @throways

2 Likes

This was confusing me too! I am glad its not my computer/network!
It worked after a while randomly once after re-installing the entire game, and trying a few more times.

But since last night I can not log in again.
The solution was

sudo sysctl -w net.ipv4.ip_default_ttl=128

2 Likes

this fixed it for me too thanks.

Related issue though is retail is messed up. It logs in but the WOW window is frozen graphically. Can hear my character reacting to keys I press.

I figured I would have to wait till blizzard got everything worked out, but I got this to work. Thanks for the info