Back to the main site

Can't launch epic games

Hello, i tried to download epic games launcher from lutris, and it works but it won’t launch. I tried alot of things but my knowledge of linux is weak.
I got this error il the log :
Started initial process 36910 from /home/robertelcocinero/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/bin/wine /home/robertelcocinero/Games/epic-games-store/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe -openGl -SkipBuildPatchPrereq
Start monitoring process.
Monitored process exited.
Initial process has exited (return code: 0)
All processes have quit
Exit with return code 0

1 Like

Hola Señor Cocinero,
What do you mean that it works but it won’t load? You mean a game will not launch?

The log looks clean.

1 Like

Nothing happen, the stop button become the start button again. Nothing launch.
I search all i Can on the log because i don’t know where i see what IS the problem
( Sorry for my Bad english )

Please check the instructions for Obtaining log output for games here:

https://forums.lutris.net/t/please-read-before-asking-for-help/3727/4

Can you try to run it with your native wine version (the one that your distribution provide) or try to run it with lutris-7.2 wine version?

You can change wine version that lutris use to run Windows apps (here you change by select a “Wine version”)

Most of the windows app will works with default wine version but some will require you to choose another wine version or “Disable Lutris Runtime” injection or both to make that specific app to work well

If you are dont want to deal with Lutris Epic Games installation then you can use Heroic Game Launcher instead - Its lightweight, powerful, have linux dedicated client and way more stable than Epic Games Launcher official version.

1 Like

I haven’t run the Epic Store in a while, but I tried to load it tonight. It made me update, and so I let it. It took quite a few minutes on a black screen with a blue bar at the bottom… so long that I was tempted to close it, but then it did eventually open, so there is hope. It can work.

I’m using mostly default settings in Lutris, but a few notables are:

.../epic-games-store/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe

with arguments

-opengl -SkipBuildPatchPrereq

Wine is lutris-fshack-6.13-3-x86_64 and is running in a 64-bit bottle.
DXVK/VKD3D is enabled (DXVK v1.10L). Xephyr fullscreen is on.

$ winetricks list-installed
Executing mkdir -p /home/apps/Lutris
------------------------------------------------------
warning: You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
------------------------------------------------------
Using winetricks 20220411-next - sha256sum: d23dbdf84a2f75b0cbb9608f9ba9d65ee23947fdf71be76115c9eb066b3b3100 with wine-6.14.r0.g069adfd1 ( TkG Staging Esync Fsync ) and WINEARCH=win64
w_workaround_wine_bug-24013
d3dcompiler_43
d3dcompiler_47
d3dx9
andale
arial
comicsans
courier
georgia
impact
times
trebuchet
verdana
webdings
corefonts

I don’t recall what resource I used to help me know how to install, sorry.

Sorry for me asking help and couldn’t ansewer, i’m back and thanks for your help, i tried to solve the problem with a guy on discord but we end up having nothing :’(. I got this
for submit-issue : Ubuntu Pastebin
for lutris -d : Ubuntu Pastebin

And this ( 2 links limited )
for the Epic games logs : Ubuntu Pastebin
inxi -SMGxx command : Ubuntu Pastebin

Your “lutris -d” is incomplete, you need to run that command and then try to reproduce the issue.

What you have in your pastebin is just lutris launching.

Please try to run EGS with the lutris -d

Here, and thanks for your help :slight_smile:
https://paste.ubuntu.com/p/hwcQPpsjkk/

Everything still looks clean. Code 0 means that the program ran without issues. I would suggest you install a custom wine with protonup-qt. Install the latest Wine GE you see in there and configure the Launcher to use this wine version.

So we finish on a surrender because nothing seems to work i also tried to download bottle but it didn’t work too :frowning: ( i already tried configure different wine version )

Have you tried following hints taken from:

Clearly, the guide would not be identical for you unless you ran Manjaro, but the list of Linux packages could give a clue what distribution packages your system might need. I know this says without Lutris, but the still the hints of packages needed could still be relevant to a Lutris install. It also talks about winetricks, which also are relevant to a Lutris install.

Also here is a reference to the Heroic launcher @bluesaka111 suggested:

:crossed_fingers:

Epic Games Store is supported by another potential route:

https://usebottles.com/database/installers/