Back to the main site

Can't install WoW from battlenet


#1

Hey,
I can’t install battle.net from the battlenet launcher installer, nor from the WoW installer.
I press the “Install” button after I logon, and then nothing happens.

If I point it towards the installation folder of WoW it wants to update, so I press update but then, again, nothing happens.

I have tried both:

Fresh install of the latest Ubuntu release. Only thing I have done is that I have installed Nvidia drivers and I have installed the latest kernel using “ukuu kernel updater”, installed Discord and Chrome

Would anyone please help me? I can provide logs, if you tell me where to find the logs you need


#2

You can try https://www.gloriouseggroll.tv/how-to-get-out-of-wine-dependency-hell/, also make sure you have the 32bit graphics driver also installed.


#3

Try deleting C:\ProgramData\Battle.net


#4

Right click on WoW in Lutris and go to configure, select battle.net.exe, right click the game in lutris and go to Winetricks, in winetricks click ok to “select default wine prefix” then install modules, scroll down and install “IE8, VCredist 2015”, also using Winetricks click “install fonts” install “core fonts”.

Also right click Wine configuration and change OS emulation to Win2008 R2.

This fixed a similar issue with me


#5

Did you follow the instructions posted on the lutris page of the script to first install the dependencies required by the Battle.net app?


#6

Hello,

I believe I’m having the same issue, I had the previous wow install and it worked (did all the wine dependencies etc) and now I have installed the new installer and battle.net opens but when I click on install (Wow or any game) I get a pop up window with “World of warcraft installation” and nothing happens.

Any ideas?

Thanks


#7

Check system monitor: I noticed I had three or four instances of agent.exe running in the background. Shut them down together with everything wine related. Then try again. (You might have to also delete C:\ProgramData\Battle.net as stated above.) This worked for me and I could start the installation.


#8

Can you try esync-3.13? and/or staging-3.13