Can't install WoW/

Hey there,

Followed the install instructions for Ubuntu but I’m on the new Linux Mint 19. I get all the way to the App login window but as soon as the window loads the google and Facebook buttons it crashes.

This worked fine for me a few days ago on Solus but won’t work there now anymore either. I also tried Manjaro, same exact problem.

I’m on an AMD system. I haven’t done anything outside of the install instructions. This is a fresh install. Hope someone can help. Thanks

Have you tried using this ( installer? I just used the top one, and the only issue I had was my NVIDIA driver is a wee bit behind the required mark for usage of the latest DXVK in the script (0.61). Knocking back that to 0.54 fixed everything for me.

Not sure about much AMD GPU-wise, but I am sure if you ask how to install your drivers and vulkan you will get a good answer on the Mint forums (or google it). I am a Red Hat & Fedora user here, so a bit useless on the driver portion. Sorry there.

Quick question regarding upgrading/downgrading DXVK versions via lutris. Is this achieved simply by changing the DXVK version under the “Runner Options” tab? Or do I need to update the SDK via winetricks in the particular prefix also? I’m pretty new to this, please bare with me.

Change the version under ‘Runner Options’ and it will automatically download and use that version.

Data, did this start after that last update?

No idea. It worked Monday on a freshly built box. Then Tuesday on a freshly built one it didn’t. Not sure if bnet was updated between then.

Just tried again on a fresh Manjaro. Same thing. Install of bnet happens fine. Login window comes up and crashes 2 seconds later.

Are you using the script I linked to?