Can't install previously installed games: Error 256


I’ve just switched over from regular Lutris to Lutris Flatpak and I keep getting this error when I try to install any games that I previously had installed with the regular version of Lutris: “Command exited with code 256”.

Here’s an example from the last attempt at installing a game (Red Dead Redemption 2):

Executing /home/user/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-GE-Proton7-28-x86_64/bin/wine vc_redist.x64.exe /q
Application could not be started, or no application associated with the specified file.
ShellExecuteEx failed: File not found.

warning: Note: command /home/user/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-GE-Proton7-28-x86_64/bin/wine vc_redist.x64.exe /q returned status 1. Aborting.

Monitored process exited.
Initial process has exited (return code: 256)
Exit with return code 256

I’ve tried deleting any leftover Lutris files from the previous install just incase they have an effect and I’ve also tried deleting the .wine folder in Home as some people suggest but it still doesn’t work.

I am able to install and run games that weren’t previously installed - it’s just the ones I had installed before.

The runner mentioned in the above text does exist in that location so I’m not sure why it’s saying that.

I’ve tried installing these games fresh and also with the previously existing files in place but neither way works.

It doesn’t seem to be a permission problem as far as I can tell due to the fact it can install and run other games.

I’m on Nobara (Fedora based), by the way.

I don’t get it… Any ideas?

Thanks :wink:

1 Like